Bug 59930 - Make fast/dom/object-embed-plugin-scripting.html compatible with non-Mac ports
Summary: Make fast/dom/object-embed-plugin-scripting.html compatible with non-Mac ports
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Robert Hogan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-02 05:39 PDT by Robert Hogan
Modified: 2011-05-16 15:19 PDT (History)
8 users (show)

See Also:


Attachments
Patch (4.74 KB, patch)
2011-05-02 05:44 PDT, Robert Hogan
no flags Details | Formatted Diff | Diff
Patch (16.59 KB, patch)
2011-05-02 05:46 PDT, Robert Hogan
no flags Details | Formatted Diff | Diff
Patch (4.73 KB, patch)
2011-05-10 10:46 PDT, Robert Hogan
no flags Details | Formatted Diff | Diff
Patch (1.36 KB, patch)
2011-05-16 11:13 PDT, Robert Hogan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Hogan 2011-05-02 05:39:50 PDT
Move fast/dom/object-embed-plugin-scripting.html to plugins/ and change it to use the test plugin rather than quicktime. This allows it to pass on Qt and Chromium Linux ports.
Comment 1 Robert Hogan 2011-05-02 05:44:43 PDT
Created attachment 91914 [details]
Patch
Comment 2 Robert Hogan 2011-05-02 05:46:05 PDT
Created attachment 91915 [details]
Patch
Comment 3 Eric Seidel (no email) 2011-05-02 10:10:14 PDT
Comment on attachment 91915 [details]
Patch

LGTM.
Comment 4 WebKit Commit Bot 2011-05-03 10:48:18 PDT
Comment on attachment 91915 [details]
Patch

Rejecting attachment 91915 [details] from commit-queue.

Failed to run "['./Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=cr-jail-7', 'apply-..." exit_code: 2

Last 500 characters of output:
rm/chromium/test_expectations.txt
patching file LayoutTests/platform/qt/Skipped
patching file LayoutTests/plugins/object-embed-plugin-scripting-expected.txt
patching file LayoutTests/plugins/object-embed-plugin-scripting.html
LayoutTests/plugins/resources/apple.gif: unknown git binary patch format at /mnt/git/webkit-commit-queue/Tools/Scripts/VCSUtils.pm line 1825.

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--reviewer', u'Eric Seidel', u'--force']" exit_code: 29

Full output: http://queues.webkit.org/results/8533416
Comment 5 Eric Seidel (no email) 2011-05-03 11:00:53 PDT
Looks like svn-apply is still sick?
Comment 6 Robert Hogan 2011-05-10 10:46:28 PDT
Created attachment 92978 [details]
Patch
Comment 7 WebKit Commit Bot 2011-05-10 10:51:00 PDT
Comment on attachment 92978 [details]
Patch

Rejecting attachment 92978 [details] from commit-queue.

Failed to run "['./Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=cr-jail-7', 'apply-..." exit_code: 2

Last 500 characters of output:
m bug 59930.
Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--force']" exit_code: 2

Parsed 5 diffs from patch file(s).
patching file LayoutTests/ChangeLog
patch: **** Only garbage was found in the patch input.
rm 'LayoutTests/fast/dom/resources/articles.m4a'
patching file LayoutTests/platform/chromium/test_expectations.txt
patching file LayoutTests/platform/qt/Skipped

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--force']" exit_code: 2

Full output: http://queues.webkit.org/results/8684044
Comment 8 Daniel Bates 2011-05-10 10:55:00 PDT
(In reply to comment #6)
> Created an attachment (id=92978) [details]
> Patch

How did you create this patch?
Comment 9 Robert Hogan 2011-05-10 10:57:36 PDT
(In reply to comment #8)
> (In reply to comment #6)
> > Created an attachment (id=92978) [details] [details]
> > Patch
> 
> How did you create this patch?

git. is there something wrong with props of the gif?
Comment 10 Daniel Bates 2011-05-10 16:43:33 PDT
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #6)
> > > Created an attachment (id=92978) [details] [details] [details]
> > > Patch
> > 
> > How did you create this patch?
> 
> git. is there something wrong with props of the gif?

No. The issue is that this patch contains a diff that removes an empty file. Unfortunately svn-{apply, unapply} fails to handle such diffs. We need to fix bug #29684. Therefore, we cannot land this patch via the commit queue; => we will need to land this patch by hand.
Comment 11 Daniel Bates 2011-05-10 16:44:58 PDT
(In reply to comment #10)
> No. The issue is that this patch contains a diff that removes an empty file. 

For completeness, the empty file that is being removed is LayoutTests/fast/dom/resources/articles.m4a.
Comment 12 Robert Hogan 2011-05-13 09:59:09 PDT
Committed r86440: <http://trac.webkit.org/changeset/86440>
Comment 13 Csaba Osztrogonác 2011-05-14 02:25:28 PDT
(In reply to comment #12)
> Committed r86440: <http://trac.webkit.org/changeset/86440>

fast/dom/object-embed-plugin-scripting.html fails on our Qt Snow Leopard bot:
http://build.webkit.sed.hu/waterfall

Could you fix it, or add this test to qt-mac/Skipped list?


--- /buildbot/snowleopard-qt-release/snowleopard-qt-intel-release/build/layout-test-results/plugins/object-embed-plugin-scripting-expected.txt	2011-05-14 01:59:22.000000000 -0700
+++ /buildbot/snowleopard-qt-release/snowleopard-qt-intel-release/build/layout-test-results/plugins/object-embed-plugin-scripting-actual.txt	2011-05-14 01:59:22.000000000 -0700
@@ -2,22 +2,22 @@
 
 Each test below states its expected outcome.
 
-plugin <object> with nested plugin <embed>: should have a plugin and does
+plugin <object> with nested plugin <embed>: should have a plugin and does not
 
-plugin <embed> netsted in plugin <object>: should have a plugin and does
+plugin <embed> netsted in plugin <object>: should have a plugin and does not
 
 empty <object> with nested plugin <embed>: should not have a plugin and does not
 
-plugin <embed> nested in empty <object>: should have a plugin and does
+plugin <embed> nested in empty <object>: should have a plugin and does not
 
 plugin <embed> nested in image <object>: should not have a plugin and does not
 
 plugin <embed> nested in empty <object> nested in plugin <object>: should not have a plugin and does not
 
-standalone plugin <embed>: should have a plugin and does
+standalone plugin <embed>: should have a plugin and does not
 
-plugin <object> with nested plugin <embed> of the same name should have a plugin and does
+plugin <object> with nested plugin <embed> of the same name should have a plugin and does not
 
-empty <object> with nested plugin <embed> of the same name should have a plugin and does
+empty <object> with nested plugin <embed> of the same name should have a plugin and does not
Comment 14 Csaba Osztrogonác 2011-05-16 07:58:06 PDT
Robert, could you make the Qt Mac bot green again, please?
Comment 15 Robert Hogan 2011-05-16 11:13:30 PDT
Created attachment 93672 [details]
Patch
Comment 16 Csaba Osztrogonác 2011-05-16 11:49:10 PDT
Comment on attachment 93672 [details]
Patch

r=me
Comment 17 WebKit Commit Bot 2011-05-16 15:17:39 PDT
The commit-queue encountered the following flaky tests while processing attachment 93672 [details]:

http/tests/websocket/tests/bad-handshake-crash.html bug 54370 (author: abarth@webkit.org)
The commit-queue is continuing to process your patch.
Comment 18 WebKit Commit Bot 2011-05-16 15:19:28 PDT
Comment on attachment 93672 [details]
Patch

Clearing flags on attachment: 93672

Committed r86613: <http://trac.webkit.org/changeset/86613>
Comment 19 WebKit Commit Bot 2011-05-16 15:19:34 PDT
All reviewed patches have been landed.  Closing bug.