Bug 59612 - [GTK] Enable c++0x support when g++ version >= 4.6.0
Summary: [GTK] Enable c++0x support when g++ version >= 4.6.0
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 59610 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-27 08:51 PDT by Alexandre Mazari
Modified: 2015-05-07 17:41 PDT (History)
4 users (show)

See Also:


Attachments
Patch (766 bytes, patch)
2011-04-27 08:52 PDT, Alexandre Mazari
ap: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Mazari 2011-04-27 08:51:16 PDT
[GTK] Enable c++0x support when g++ version >= 4.6.0
Comment 1 Alexandre Mazari 2011-04-27 08:52:21 PDT
Created attachment 91294 [details]
Patch
Comment 2 Collabora GTK+ EWS bot 2011-04-27 09:11:31 PDT
Attachment 91294 [details] did not build on gtk:
Build output: http://queues.webkit.org/results/8513374
Comment 3 Xan Lopez 2011-04-27 10:13:14 PDT
This is not really going to work, you need a lot of fixes before you can activate C++0x support (as you can see by the failed compile).

I've already uploaded some of them:

https://bugs.webkit.org/show_bug.cgi?id=59249
https://bugs.webkit.org/show_bug.cgi?id=59252
https://bugs.webkit.org/show_bug.cgi?id=59261
https://bugs.webkit.org/show_bug.cgi?id=59477
Comment 4 Alexey Proskuryakov 2011-04-27 14:11:21 PDT
Comment on attachment 91294 [details]
Patch

r- for breaking the build, and no ChangeLog.
Comment 5 Alexey Proskuryakov 2011-04-27 14:15:56 PDT
*** Bug 59610 has been marked as a duplicate of this bug. ***
Comment 6 Martin Robinson 2015-05-07 17:41:06 PDT
I think we have C++11 support now. :)