Bug 59044 - [Qt][WK2] Emit QWKPage::urlChanged() when navigating within the same document.
Summary: [Qt][WK2] Emit QWKPage::urlChanged() when navigating within the same document.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Andreas Kling
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2011-04-20 17:16 PDT by Andreas Kling
Modified: 2011-04-21 12:32 PDT (History)
1 user (show)

See Also:


Attachments
Proposed patch (3.10 KB, patch)
2011-04-20 17:17 PDT, Andreas Kling
kenneth: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kling 2011-04-20 17:16:42 PDT
SSIA
Comment 1 Andreas Kling 2011-04-20 17:17:31 PDT
Created attachment 90453 [details]
Proposed patch
Comment 2 WebKit Review Bot 2011-04-20 17:20:15 PDT
Attachment 90453 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit2/ChangeLog', u'Source/WebKit..." exit_code: 1

Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46:  The parameter name "page" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46:  The parameter name "frame" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46:  The parameter name "type" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 3 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Kenneth Rohde Christiansen 2011-04-21 03:57:07 PDT
Comment on attachment 90453 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=90453&action=review

>>>> Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46
>>>> +void qt_wk_didSameDocumentNavigationForFrame(WKPageRef page, WKFrameRef frame, WKSameDocumentNavigationType type, WKTypeRef userData, const void *clientInfo);
>>> 
>>> The parameter name "page" adds no information, so it should be removed.  [readability/parameter_name] [5]
>> 
>> The parameter name "frame" adds no information, so it should be removed.  [readability/parameter_name] [5]
> 
> The parameter name "type" adds no information, so it should be removed.  [readability/parameter_name] [5]

I agree with the style guide here :-) only clientInfo and userData brings value
Comment 4 Andreas Kling 2011-04-21 12:32:17 PDT
Committed r84539: <http://trac.webkit.org/changeset/84539>