Bug 58740 - REGRESSION (r83803): Focused plug-ins have a focus ring in Safari
Summary: REGRESSION (r83803): Focused plug-ins have a focus ring in Safari
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P1 Major
Assignee: Nobody
URL:
Keywords: InRadar, Regression
: 58782 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-16 23:24 PDT by mitz
Modified: 2011-04-18 10:41 PDT (History)
7 users (show)

See Also:


Attachments
Screen shot (from another page) (222.14 KB, image/png)
2011-04-16 23:30 PDT, mitz
no flags Details
Screen Shot (chrome-mac, 12.0.740.0 (81927) ToT) (241.07 KB, image/png)
2011-04-18 02:56 PDT, noel gordon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2011-04-16 23:24:59 PDT
To reproduce, go to <http://www.youtube.com/apple> and click inside the video. Note a focus ring around the bottom and right sides of the plug-in (top and left are clipped out). Looks like a regression caused by <http://trac.webkit.org/changeset/83803>.
Comment 1 mitz 2011-04-16 23:25:37 PDT
<rdar://problem/9295879>
Comment 2 mitz 2011-04-16 23:30:51 PDT
Created attachment 89940 [details]
Screen shot (from another page)
Comment 3 mitz 2011-04-16 23:58:30 PDT
Note: I can only reproduce this in WebKit2.
Comment 4 mitz 2011-04-17 00:00:27 PDT
(In reply to comment #3)
> Note: I can only reproduce this in WebKit2.

Perhaps due to <http://trac.webkit.org/changeset/83306>?
Comment 5 Abhishek Arya 2011-04-17 09:14:07 PDT
I put in the breakpoints in my code call, it never hits in Chrome. This looks like some webkit2 specific change.
Comment 6 noel gordon 2011-04-18 02:53:59 PDT
I can reproduce in chrome-mac.
Comment 7 noel gordon 2011-04-18 02:56:01 PDT
Created attachment 90010 [details]
Screen Shot (chrome-mac, 12.0.740.0 (81927) ToT)
Comment 8 Abhishek Arya 2011-04-18 07:45:49 PDT
Thanks Noel. I can also reproduce on chrome mac (was earlier testing on chrome win). When i commented out my patch lines, the focus ring went away. Rolled out my patch for now - http://trac.webkit.org/changeset/84143.
Comment 9 Abhishek Arya 2011-04-18 10:41:02 PDT
*** Bug 58782 has been marked as a duplicate of this bug. ***