Since FileWriter API is not yet standard, we should vendor-prefix BlobBuilder.
(As for FileWriter it cannot be created without requesting FileSystem, whose entry point will be prefixed as well, we won't need to prefix it separately.)
window.BlobBuilder -> window.webkitBlobBuilder
Shouldn't it be WebKitBlobBuilder, like WebKitPoint? Things you can construct start with an upper-case letter, right?
Created attachment 89631 [details]