RESOLVED FIXED Bug 58517
Vendor-prefix requestFileSystem in FileSystem API
https://bugs.webkit.org/show_bug.cgi?id=58517
Summary Vendor-prefix requestFileSystem in FileSystem API
Kinuko Yasuda
Reported 2011-04-13 23:25:05 PDT
Since FileSystem API is not standard yet and will likely change, we should vendor-prefix the exposed API. Specifically: window.requestFileSystem should be renamed to window.webkitRequestFileSystem.
Attachments
Patch (40.37 KB, patch)
2011-04-14 05:10 PDT, Taiju Tsuiki
no flags
Patch (83.72 KB, patch)
2011-04-17 19:02 PDT, Taiju Tsuiki
no flags
Patch (83.78 KB, patch)
2011-04-17 22:01 PDT, Taiju Tsuiki
no flags
Patch (250.87 KB, patch)
2011-04-17 22:58 PDT, Taiju Tsuiki
no flags
Patch (89.49 KB, patch)
2011-04-17 23:06 PDT, Taiju Tsuiki
no flags
Patch (90.41 KB, patch)
2011-04-18 00:20 PDT, Taiju Tsuiki
no flags
Kinuko Yasuda
Comment 1 2011-04-13 23:36:23 PDT
I guess following APIs should also be prefixed? window.resolveLocalFileSystemURL WorkerContext.requestFileSystem WorkerContext.requestFileSystemSync WorkerContext.resolveLocalFileSystemURL WorkerContext.resolveLocalFileSystemSyncURL
Taiju Tsuiki
Comment 2 2011-04-14 05:10:23 PDT
Kinuko Yasuda
Comment 3 2011-04-14 06:14:28 PDT
Comment on attachment 89557 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=89557&action=review > Source/WebCore/ChangeLog:6 > + https://bugs.webkit.org/show_bug.cgi?id=58517 Looks good, thanks for working on this. I think it'd be better to add some explanation why and how (which method) we're prefixing in the ChangeLog. (Probably you can just copy and paste the explanation from the bug.)
Darin Fisher (:fishd, Google)
Comment 4 2011-04-14 09:02:07 PDT
Comment on attachment 89557 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=89557&action=review > Source/WebCore/page/DOMWindow.idl:200 > attribute [EnabledAtRuntime=FileSystem] FlagsConstructor Flags; What about Flags? Should this be WebKitFlags for completeness? (I think it is OK to leave TEMPORARY and PERSISTENT as is... just not sure about Flags.)
Eric U.
Comment 5 2011-04-14 09:24:29 PDT
Comment on attachment 89557 [details] Patch What about the flags TEMPORARY and PERSISTENT? Should we prefix them too?
Eric U.
Comment 6 2011-04-14 09:25:16 PDT
(In reply to comment #5) > (From update of attachment 89557 [details]) > What about the flags TEMPORARY and PERSISTENT? Should we prefix them too? Sorry--missed your comment. Nevermind.
Taiju Tsuiki
Comment 7 2011-04-17 19:02:10 PDT
WebKit Review Bot
Comment 8 2011-04-17 19:24:42 PDT
Build Bot
Comment 9 2011-04-17 19:57:37 PDT
Early Warning System Bot
Comment 10 2011-04-17 20:00:56 PDT
Taiju Tsuiki
Comment 11 2011-04-17 22:01:51 PDT
WebKit Review Bot
Comment 12 2011-04-17 22:09:34 PDT
Build Bot
Comment 13 2011-04-17 22:57:14 PDT
Taiju Tsuiki
Comment 14 2011-04-17 22:58:58 PDT
Taiju Tsuiki
Comment 15 2011-04-17 23:06:38 PDT
Taiju Tsuiki
Comment 16 2011-04-18 00:20:03 PDT
Kinuko Yasuda
Comment 17 2011-04-18 06:38:05 PDT
(In reply to comment #16) > Created an attachment (id=89999) [details] > Patch Thanks for working on this. The patch looks good to me. (Could any 'real' reviewer take a look at the patch?)
WebKit Commit Bot
Comment 18 2011-04-18 22:36:53 PDT
Comment on attachment 89999 [details] Patch Clearing flags on attachment: 89999 Committed r84224: <http://trac.webkit.org/changeset/84224>
WebKit Commit Bot
Comment 19 2011-04-18 22:37:01 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.