Bug 58510 - webkit-patch upload failed on new binary files
Summary: webkit-patch upload failed on new binary files
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-13 21:42 PDT by Simon Fraser (smfr)
Modified: 2011-04-14 09:55 PDT (History)
4 users (show)

See Also:


Attachments
PrettyPatch output (287.94 KB, text/plain)
2011-04-13 21:42 PDT, Simon Fraser (smfr)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2011-04-13 21:42:08 PDT
Doing a 'webkit-patch upload' on some local (staged) changes in my git repo that included new PNG files failed with:

Exception raised during decoding git binary patch:
can't convert nil into String
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:538:in `pack'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:538:in `initialize'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:538:in `collect'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:538:in `initialize'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:603:in `new'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:603:in `parse'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:603:in `collect'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:603:in `parse'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/PrettyPatch.rb:16:in `prettify'
/Volumes/Monster/Development/apple/webkit/WebKit.git/Websites/bugs.webkit.org/PrettyPatch/prettify.rb:26
Comment 1 Simon Fraser (smfr) 2011-04-13 21:42:30 PDT
Created attachment 89528 [details]
PrettyPatch output
Comment 2 Simon Fraser (smfr) 2011-04-13 21:43:43 PDT
The PNG files are missing from the patch:
https://bugs.webkit.org/attachment.cgi?id=89529&action=review
Comment 3 Simon Fraser (smfr) 2011-04-13 21:54:01 PDT
The actual patch is at https://bug-58457-attachments.webkit.org/attachment.cgi?id=89529
Comment 4 Simon Fraser (smfr) 2011-04-13 22:02:11 PDT
This was caused by http://trac.webkit.org/changeset/83750
Comment 5 Simon Fraser (smfr) 2011-04-13 22:06:19 PDT
http://trac.webkit.org/changeset/83811
Comment 6 Tony Chang 2011-04-14 09:55:20 PDT
Sorry for the breakage and thanks for rolling out.