Bug 58403 - Rename onEndChain and make it a static method.
Summary: Rename onEndChain and make it a static method.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-12 17:28 PDT by Yael
Modified: 2011-04-12 18:37 PDT (History)
1 user (show)

See Also:


Attachments
Patch. (3.33 KB, patch)
2011-04-12 17:34 PDT, Yael
eric: review+
eric: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yael 2011-04-12 17:28:34 PDT
The method onEndChain should be renamed and should become static.
Comment 1 Eric Seidel (no email) 2011-04-12 17:28:54 PDT
Thanks.
Comment 2 Yael 2011-04-12 17:34:41 PDT
Created attachment 89316 [details]
Patch.
Comment 3 Eric Seidel (no email) 2011-04-12 17:46:28 PDT
Comment on attachment 89316 [details]
Patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=89316&action=review

Otherwise LGTM.  If you're a committer, you can just add the two keywords when you land, otherwise you'll need to post a new patch.  Thanks!

> Source/WebCore/rendering/InlineFlowBox.cpp:255
> +bool isLastChildForRenderer(RenderObject* ancestor, RenderObject* child)

Should mark it static and possibly inline.
Comment 4 Yael 2011-04-12 17:54:42 PDT
(In reply to comment #3)
> (From update of attachment 89316 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=89316&action=review
> 
> Otherwise LGTM.  If you're a committer, you can just add the two keywords when you land, otherwise you'll need to post a new patch.  Thanks!
> 
> > Source/WebCore/rendering/InlineFlowBox.cpp:255
> > +bool isLastChildForRenderer(RenderObject* ancestor, RenderObject* child)
> 
> Should mark it static and possibly inline.

Terribly sorry, I forgot to mark it static. Thanks for catching it.
I'll mark it inline if the compiler agrees :)
Comment 5 Yael 2011-04-12 18:37:32 PDT
Committed r83679: <http://trac.webkit.org/changeset/83679>