Bug 58306 - compositing/webgl/webgl-nonpremultiplied-blend.html crashes on Mac OS X 10.6, Chromium DEBUG build
Summary: compositing/webgl/webgl-nonpremultiplied-blend.html crashes on Mac OS X 10.6,...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Major
Assignee: John Bates
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-12 01:48 PDT by Andrey Kosyakov
Modified: 2013-04-08 13:59 PDT (History)
5 users (show)

See Also:


Attachments
Stack trace for crash (8.21 KB, text/plain)
2011-04-12 14:26 PDT, Kenneth Russell
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Kosyakov 2011-04-12 01:48:08 PDT
compositing/webgl/webgl-nonpremultiplied-blend.html crashes on Mac OS X 10.6, Chromium DEBUG build
Apparently, this started after r83552.
Comment 1 Kenneth Russell 2011-04-12 13:32:35 PDT
This is reproducible. It seems necessary to reload the page and then wait a second. The following is printed to the console when the renderer crashes:

ASSERTION FAILED: !m_deletionHasBegun
../../JavaScriptCore/wtf/RefCounted.h(37) : void WTF::RefCountedBase::ref()

This is likely caused by the HashMap of RefPtrs to GraphicsContext3D instances.
Comment 2 John Bates 2011-04-12 14:21:14 PDT
(In reply to comment #1)
> This is reproducible. It seems necessary to reload the page and then wait a second. The following is printed to the console when the renderer crashes:
> 
> ASSERTION FAILED: !m_deletionHasBegun
> ../../JavaScriptCore/wtf/RefCounted.h(37) : void WTF::RefCountedBase::ref()
> 
> This is likely caused by the HashMap of RefPtrs to GraphicsContext3D instances.

The crash does not seem to happen in Linux -- I tried lots of reloading, duplicating and closing the tab. Is it trivial for you to post the call stack from Mac?
Comment 3 Kenneth Russell 2011-04-12 14:25:47 PDT
Yes. I'll add it as an attachment since it's large.
Comment 4 Kenneth Russell 2011-04-12 14:26:34 PDT
Created attachment 89270 [details]
Stack trace for crash
Comment 5 Andrey Kosyakov 2011-04-12 22:54:20 PDT
I'm also marking media/adopt-node-crash.html as CRASH with a reference to this bug, as it started crashing on GPU tests on Mac SL debug since about the same time:

http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.6%20%28dbg%29/builds/481