Bug 58201 - REGRESSION(r83384): Change to chromium.py is resulting in failures of the test framework on linux.
Summary: REGRESSION(r83384): Change to chromium.py is resulting in failures of the tes...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: David Levin
URL:
Keywords:
Depends on:
Blocks: 58202
  Show dependency treegraph
 
Reported: 2011-04-10 08:41 PDT by David Levin
Modified: 2011-04-10 14:28 PDT (History)
2 users (show)

See Also:


Attachments
Patch (1.52 KB, patch)
2011-04-10 08:53 PDT, David Levin
dglazkov: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 David Levin 2011-04-10 08:53:53 PDT
Created attachment 88950 [details]
Patch
Comment 2 David Levin 2011-04-10 08:55:00 PDT
See dependent bug for the follow up to remove the fixme (and do a better fix).
Comment 3 Dimitri Glazkov (Google) 2011-04-10 08:58:20 PDT
Comment on attachment 88950 [details]
Patch

ok.
Comment 4 David Levin 2011-04-10 09:01:45 PDT
Committed as http://trac.webkit.org/changeset/83398
Comment 5 Dirk Pranke 2011-04-10 14:28:08 PDT
From looking at the python code implementing subprocess, it looks like either os.waitpid() could be returning something weird, or it could be raising os.error.

So, something's definitely wrong, but having NRWT fall over at that point isn't all that useful, so your change is good. I will see if I can follow-up and reproduce it in bug 58202.