Bug 58169 - Make the drag operations be different functions
Summary: Make the drag operations be different functions
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
Depends on:
Reported: 2011-04-08 15:54 PDT by Anders Carlsson
Modified: 2011-04-08 16:00 PDT (History)
0 users

See Also:

Patch (8.32 KB, patch)
2011-04-08 15:56 PDT, Anders Carlsson
aroben: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2011-04-08 15:54:53 PDT
Make the drag operations be different functions
Comment 1 Anders Carlsson 2011-04-08 15:56:07 PDT
Created attachment 88889 [details]
Comment 2 Adam Roben (:aroben) 2011-04-08 15:57:44 PDT
Comment on attachment 88889 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=88889&action=review

> Source/WebKit2/UIProcess/WebPageProxy.h:699
> +    void performDragControllerAction(DragControllerAction, WebCore::DragData*, const String& = String());

I guess this doesn't need a default value anymore.

It would be nice to name the last parameter in this function and the new ones you added. The signature is a bit mysterious without it.
Comment 3 Anders Carlsson 2011-04-08 16:00:36 PDT
Committed r83354: <http://trac.webkit.org/changeset/83354>