Bug 58055 - REGRESSION(WebKit2): execCommand('undo') doesn't work (Mac)
Summary: REGRESSION(WebKit2): execCommand('undo') doesn't work (Mac)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Enrica Casucci
URL:
Keywords: InRadar, PlatformOnly
Depends on:
Blocks:
 
Reported: 2011-04-07 10:01 PDT by Enrica Casucci
Modified: 2018-10-11 15:36 PDT (History)
1 user (show)

See Also:


Attachments
Patch (16.15 KB, patch)
2011-04-07 11:27 PDT, Enrica Casucci
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Enrica Casucci 2011-04-07 10:01:04 PDT
Undo does not seem to work via execCommand in WebKit2 windows.

Steps to reproduce:
1) Load exec-command-undo.html tests

Results:

Text is bold because the undo failed.
Comment 1 Enrica Casucci 2011-04-07 10:04:24 PDT
<rdar://problem/8862023>
Comment 2 Enrica Casucci 2011-04-07 11:27:06 PDT
Created attachment 88666 [details]
Patch
Comment 3 Enrica Casucci 2011-04-07 11:58:00 PDT
http://trac.webkit.org/changeset/83194