Bug 57925 - Linking error in WebKit GTK on Darwin.
Summary: Linking error in WebKit GTK on Darwin.
Status: RESOLVED DUPLICATE of bug 58443
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Major
Assignee: Nobody
URL: N/A
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-05 23:29 PDT by devchan1
Modified: 2011-04-13 08:15 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description devchan1 2011-04-05 23:29:09 PDT
When building WebKit GTK from svn source revision 83015, the following linking error occurs
near the end of the build.

ld: duplicate symbol WebCore::MIMETypeRegistry::getMIMETypeForExtension(WTF::String const&)  in ./.libs/libWebCore.a(libWebCore_la-MIMETypeRegistry.o) and Source/WebCore/platform/gtk/.libs/libwebkitgtk_1_0_la-MIMETypeRegistryGtk.o
collect2: ld returned 1 exit status
make[1]: *** [libwebkitgtk-1.0.la] Error 1
make: *** [all] Error 2
Comment 1 Martin Robinson 2011-04-07 16:59:44 PDT
What configure flags are you using for your compilation?
Comment 2 red47514f7 2011-04-13 01:29:16 PDT
r83689 ; Linux ; GTK build; 64-bit

Configure flags:
./autogen.sh  --prefix=\"$prefix\" --enable-3D-transforms --enable-web-sockets --enable-web-timing --enable-geolocation --enable-mathml --enable-wml --enable-xhtmlmp --enable-file-writer --enable-blob --enable-file-system --enable-directory-upload

MIMETypeRegistry.cpp:(.text+0x240): multiple definition of `WebCore::MIMETypeRegistry::getMIMETypeForExtension(WTF::String const&)'
Source/WebCore/platform/gtk/.libs/libwebkitgtk_1_0_la-MIMETypeRegistryGtk.o:MIMETypeRegistryGtk.cpp:(.text+0x0): first defined here
Comment 3 Martin Robinson 2011-04-13 08:12:37 PDT
The file system API is not fully supported yet. If you wish to use it, I encourage you to submit patches getting it building and passing all the tests.
Comment 4 Martin Robinson 2011-04-13 08:15:21 PDT

*** This bug has been marked as a duplicate of bug 58443 ***