Bug 57830 - Web Inspector:Duplicated display of storage db when running Web SQL from an iframe
Summary: Web Inspector:Duplicated display of storage db when running Web SQL from an i...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-05 05:22 PDT by Ilya Tikhonovsky
Modified: 2011-04-14 05:32 PDT (History)
10 users (show)

See Also:


Attachments
test1.html (1.99 KB, text/html)
2011-04-05 05:22 PDT, Ilya Tikhonovsky
no flags Details
parent.html (1.12 KB, text/html)
2011-04-05 05:22 PDT, Ilya Tikhonovsky
no flags Details
[patch] initial version (3.56 KB, patch)
2011-04-05 05:36 PDT, Ilya Tikhonovsky
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Tikhonovsky 2011-04-05 05:22:06 PDT
Created attachment 88204 [details]
test1.html

What steps will reproduce the problem?
1. Go to page with iframe and a database in it
2. See the Storage section in the dev tools
3. Every time the iframe is loaded the icon of the database is duplicated 

What is the expected output?
Show one single instance of the database in the dev tools

What do you see instead?
A duplicate for every reload
Comment 1 Ilya Tikhonovsky 2011-04-05 05:22:33 PDT
Created attachment 88205 [details]
parent.html
Comment 2 Ilya Tikhonovsky 2011-04-05 05:36:17 PDT
Created attachment 88206 [details]
[patch] initial version
Comment 3 Pavel Feldman 2011-04-05 05:55:59 PDT
Comment on attachment 88206 [details]
[patch] initial version

View in context: https://bugs.webkit.org/attachment.cgi?id=88206&action=review

> Source/WebCore/inspector/InspectorDatabaseAgent.cpp:224
> +        resource->setDatabase(database);

What is this needed for?
Comment 4 Ilya Tikhonovsky 2011-04-14 02:09:19 PDT
Comment on attachment 88206 [details]
[patch] initial version

This patch covers typical use cases.
The page reopens Database and we have to update our internal ref to it because the old instance of DB usually has been closed.
Comment 5 Ilya Tikhonovsky 2011-04-14 05:32:29 PDT
Comment on attachment 88206 [details]
[patch] initial version

Clearing flags on attachment: 88206

Committed r83841: <http://trac.webkit.org/changeset/83841>
Comment 6 Ilya Tikhonovsky 2011-04-14 05:32:36 PDT
All reviewed patches have been landed.  Closing bug.