Bug 57824 - [Qt] fast/ruby/overhang* tests fail
Summary: [Qt] fast/ruby/overhang* tests fail
Status: RESOLVED DUPLICATE of bug 57954
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2011-04-05 03:24 PDT by Csaba Osztrogonác
Modified: 2011-04-06 09:10 PDT (History)
6 users (show)

See Also:


Attachments
overhang-horizontal-actual.png - failing result (4.54 KB, image/png)
2011-04-05 03:41 PDT, Csaba Osztrogonác
no flags Details
overhang-vertical-actual.png - failing result (4.09 KB, image/png)
2011-04-05 03:41 PDT, Csaba Osztrogonác
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2011-04-05 03:24:50 PDT
fast/ruby/overhang-horizontal.html and fast/ruby/overhang-vertical.html 
introduced in http://trac.webkit.org/changeset/82903 and fails with
minor pixel differences.
Comment 1 Csaba Osztrogonác 2011-04-05 03:36:45 PDT
I added them to the skipped list: http://trac.webkit.org/changeset/82920
Comment 2 Csaba Osztrogonác 2011-04-05 03:41:27 PDT
Created attachment 88197 [details]
overhang-horizontal-actual.png - failing result
Comment 3 Csaba Osztrogonác 2011-04-05 03:41:52 PDT
Created attachment 88198 [details]
overhang-vertical-actual.png - failing result
Comment 5 Csaba Osztrogonác 2011-04-05 03:47:17 PDT
I think the Ahem testfont of Qt might be the culprit. Could you confirm it?
Comment 6 WebKit Review Bot 2011-04-05 04:03:23 PDT
http://trac.webkit.org/changeset/82920 might have broken Qt Linux Release minimal
Comment 7 mitz 2011-04-05 08:06:44 PDT
(In reply to comment #5)
> I think the Ahem testfont of Qt might be the culprit. Could you confirm it?

Sure looks like that's the problem again. I asked about this in WebKit-dev but no one responded, I think.
Comment 8 Csaba Osztrogonác 2011-04-05 08:17:57 PDT
(In reply to comment #7)
> (In reply to comment #5)
> > I think the Ahem testfont of Qt might be the culprit. Could you confirm it?
> 
> Sure looks like that's the problem again. I asked about this in WebKit-dev but no one responded, I think.

Thanks for looking into it. I found your mail:
https://lists.webkit.org/pipermail/webkit-dev/2011-February/015923.html

Tor Arne is our font expert, could you check it, please?
Comment 9 Csaba Osztrogonác 2011-04-06 09:10:01 PDT

*** This bug has been marked as a duplicate of bug 57954 ***