Bug 57715 - Explicitly use icu namespace for ports building with U_USING_ICU_NAMESPACE=0
: Explicitly use icu namespace for ports building with U_USING_ICU_NAMESPACE=0
Status: RESOLVED FIXED
: WebKit
Platform
: 528+ (Nightly build)
: Other Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-04-02 18:16 PST by
Modified: 2011-04-03 22:12 PST (History)


Attachments
Patch (3.29 KB, patch)
2011-04-02 18:17 PST, Nico Weber
no flags Review Patch | Details | Formatted Diff | Diff
Patch (3.26 KB, patch)
2011-04-02 18:46 PST, Nico Weber
no flags Review Patch | Details | Formatted Diff | Diff
Patch (3.58 KB, patch)
2011-04-02 20:49 PST, Nico Weber
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-04-02 18:16:20 PST
Expclicitly use icu namespace for ports building with U_USING_ICU_NAMESPACE=0
------- Comment #1 From 2011-04-02 18:17:28 PST -------
Created an attachment (id=87991) [details]
Patch
------- Comment #2 From 2011-04-02 18:46:02 PST -------
Created an attachment (id=87993) [details]
Patch
------- Comment #3 From 2011-04-02 20:16:15 PST -------
(From update of attachment 87993 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=87993&action=review

> Source/WebCore/ChangeLog:12
> +        Expclicitly use icu namespace for ports building with U_USING_ICU_NAMESPACE=0
> +        https://bugs.webkit.org/show_bug.cgi?id=57715
> +
> +        * platform/text/LocalizedNumberICU.cpp:
> +        (WebCore::createFormatterForCurrentLocale):
> +        (WebCore::numberFormatter):
> +        (WebCore::parseLocalizedNumber):
> +        (WebCore::formatLocalizedNumber):

This ChangeLog doesn't tell me why you're making this change.  I have no idea.
------- Comment #4 From 2011-04-02 20:49:06 PST -------
Created an attachment (id=87994) [details]
Patch
------- Comment #5 From 2011-04-02 21:55:23 PST -------
(From update of attachment 87994 [details])
Clearing flags on attachment: 87994

Committed r82787: <http://trac.webkit.org/changeset/82787>
------- Comment #6 From 2011-04-02 21:55:28 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #7 From 2011-04-03 21:49:56 PST -------
*** Bug 57714 has been marked as a duplicate of this bug. ***
------- Comment #8 From 2011-04-03 21:52:07 PST -------
We don't normally use namespace prefixes in .cpp files, we put using directives in the beginning (e.g. "using namespace std;").
------- Comment #9 From 2011-04-03 22:12:51 PST -------
whoopsies: https://bugs.webkit.org/show_bug.cgi?id=57742