Bug 57575 - NRWT shouldn't copy .checksum files if the checksum is in the png
Summary: NRWT shouldn't copy .checksum files if the checksum is in the png
Status: RESOLVED DUPLICATE of bug 58402
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 56286
  Show dependency treegraph
 
Reported: 2011-03-31 14:03 PDT by Tony Chang
Modified: 2011-04-21 10:53 PDT (History)
2 users (show)

See Also:


Attachments
Patch (4.84 KB, patch)
2011-04-13 15:54 PDT, Tony Chang
ojan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Chang 2011-03-31 14:03:58 PDT
Currently running --reset-results and --new-baseline always copies over the .checksum file, even if the checksum is in the png comment.  Once we don't need the .checksum file, we can remove this copy step.  We also need to delete any old .checksum files that may exist from previous baselines.
Comment 1 Tony Chang 2011-04-13 15:54:54 PDT
Created attachment 89482 [details]
Patch
Comment 2 Tony Chang 2011-04-14 10:58:28 PDT
Per discussion on 58402, I won't land this until I've updated all the existing pngs.
Comment 3 Tony Chang 2011-04-21 10:53:53 PDT
I'm going to merge this into a single patch in bug 58402.

*** This bug has been marked as a duplicate of bug 58402 ***