Bug 57407 - Tokenizer stuck in ScriptDataDoubleEscapedState
: Tokenizer stuck in ScriptDataDoubleEscapedState
Status: RESOLVED WONTFIX
Product: WebKit
Classification: Unclassified
Component: WebCore Misc.
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To: Tony Gentilcore
:
Depends on:
Blocks: 41115
  Show dependency treegraph
 
Reported: 2011-03-29 17:30 PDT by Tony Gentilcore
Modified: 2011-04-04 15:00 PDT (History)
4 users (show)

See Also:


Attachments
testcase (137 bytes, text/html)
2011-03-29 17:30 PDT, Tony Gentilcore
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Gentilcore 2011-03-29 17:30:13 PDT
Created attachment 87441 [details]
testcase

See attached test case. FF4 behaves the same way so this is likely a spec bug.

IE7-9: PASS
SF5: PASS
OP11: PASS
FF3.6: PASS
FF4: FAIL
CR10-12: FAIL
Comment 1 Adam Barth 2011-03-29 17:36:40 PDT
Crazy.  That makes very little sense.
Comment 2 Adam Barth 2011-03-29 17:40:31 PDT
No, you're just in ScriptDataDoubleEscapedState.  It's a comment inside of the script tag.  I don't remember why we have all these escape states, but it's to model something.
Comment 3 Tony Gentilcore 2011-03-29 17:43:20 PDT
tests16.dat (line 1498) has nearly this exact test case. I'm going to fire up the debugger and see what it is doing.
Comment 4 Adam Barth 2011-03-29 17:51:16 PDT
Amusingly, but bug is a victim of itself.
Comment 5 Tony Gentilcore 2011-03-29 17:54:11 PDT
Filed spec bug http://www.w3.org/Bugs/Public/show_bug.cgi?id=12398
Comment 6 Tony Gentilcore 2011-04-04 15:00:35 PDT
This is working as intended per http://www.w3.org/Bugs/Public/show_bug.cgi?id=12398