Bug 57333 - REGRESSION(r82173): Causes assertion and test failures in run-javascriptcore-tests on Windows (Requested by aroben on #webkit).
Summary: REGRESSION(r82173): Causes assertion and test failures in run-javascriptcore-...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows 7
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords: MakingBotsRed, PlatformOnly
Depends on:
Blocks: 17250
  Show dependency treegraph
 
Reported: 2011-03-29 06:49 PDT by WebKit Review Bot
Modified: 2011-03-29 10:57 PDT (History)
6 users (show)

See Also:


Attachments
ROLLOUT of r82173 (53.12 KB, patch)
2011-03-29 06:49 PDT, WebKit Review Bot
no flags Details | Formatted Diff | Diff
Patch (3.56 KB, patch)
2011-03-29 08:59 PDT, Oliver Hunt
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2011-03-29 06:49:06 PDT
http://trac.webkit.org/changeset/82173 broke the build:
Causes assertion and test failures in run-javascriptcore-tests on Windows (Requested by aroben on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2011-03-29 06:49:32 PDT
Created attachment 87307 [details]
ROLLOUT of r82173

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Oliver Hunt 2011-03-29 08:34:15 PDT
Killed the rollout as i'm looking into this now
Comment 3 Oliver Hunt 2011-03-29 08:59:58 PDT
Created attachment 87339 [details]
Patch
Comment 4 Eric Seidel (no email) 2011-03-29 09:00:42 PDT
Comment on attachment 87339 [details]
Patch

Seems reasonable.
Comment 5 Oliver Hunt 2011-03-29 09:03:54 PDT
Committed r82261: <http://trac.webkit.org/changeset/82261>
Comment 6 Adam Roben (:aroben) 2011-03-29 10:46:23 PDT
Thanks, Oliver!
Comment 7 WebKit Review Bot 2011-03-29 10:57:56 PDT
http://trac.webkit.org/changeset/82261 might have broken GTK Linux 32-bit Release
The following tests are not passing:
fast/loader/onload-willSendRequest-null-for-frame.html