Bug 5695 - mail.live.com does not work in Safari
Summary: mail.live.com does not work in Safari
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P2 Major
Assignee: Nobody
URL: http://mail.live.com
Keywords:
Depends on: 9301
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 23:26 PST by Robert
Modified: 2011-06-16 17:03 PDT (History)
5 users (show)

See Also:


Attachments
Screenshot of Windows Live Mail in Safari (74.54 KB, image/png)
2005-11-20 10:10 PST, Robert
no flags Details
Firefox Screenshot showing differences with safari. (93.94 KB, image/png)
2005-11-20 10:11 PST, Robert
no flags Details
IE 6 on Windows XP using Windows Live Mail (81.56 KB, image/png)
2005-11-20 10:25 PST, Robert
no flags Details
The Source Code for the page as shown by the 3 browser screenshots. (90.32 KB, text/html)
2005-11-20 10:29 PST, Robert
no flags Details
javascript (17.02 KB, text/html)
2005-11-20 10:33 PST, Robert
no flags Details
drag & drop script (11.51 KB, text/html)
2005-11-20 10:34 PST, Robert
no flags Details
msnextras script (8.88 KB, text/html)
2005-11-20 10:35 PST, Robert
no flags Details
msnlayout script (13.77 KB, text/html)
2005-11-20 10:35 PST, Robert
no flags Details
Windows Live Mail with Safari 2.0.3 (135.07 KB, image/png)
2006-02-15 17:31 PST, Jason Prell (superrcat)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2005-11-09 23:26:31 PST
I've noticed that Safari lacks the required support for XMLHTTP and AJAX which is being used increasingly 
by Microsoft for their new online services.

Safari cannot render or load Windows Live Mail beta which I can see will be an issue when it's released 
next year as it will lock a lot of Mac users out of their mailboxes that they had with Hotmail.

Firefox has some support for AJAX and XMLHTTP but again they need to work on things to get the sites to 
work with Firefox, is there any way of updating Safari to fully support those standards and allow Safari to 
access those sites?
Comment 1 David Harrison 2005-11-16 09:47:12 PST
Safari currently does support AJAX and XMLHttpRequest (e.g. maps.google.com).

From you reference to Windows Live Mail, are you maybe thinking of rich text webmail instead?

Regardless, please provide specific problems that need to be resolved rather than describing a general 
area.

Thanks!
Comment 2 Robert 2005-11-16 17:12:08 PST
The technology being used for Windows Live Mail is the same as that which is in use at start.com and 
the same issues arise as a result with that site as with Windows Live Mail, content fails to load properly.

Start.com currently runs in the latest versions of Firefox and Internet Explorer (although there are some 
bugs in some versions). We've received feedback questioning why we don't support additional browsers. 
The browsers we support is currently a technology driven decision. We want to support additional 
browsers, but not all browsers support the necessary standards. I am going to explain a few technical 
issues we have faced that are critical to us expanding Start.com's support.
 
First, the browser must support the DHTML event and object model. I am not going to list the specific 
standards, but assuming a browser can meet the following three requirements, the remaining support 
will most likely be sufficient.
Support for dynamically downloading code
We download most scripts by dynamically creating SCRIPT tags. Unfortunately, we have found some 
browsers do not expose any events or properties that we can use to detect the script has been loaded. 
Specifically, we have not found an appropriate onload event or readystate-type poperty in Safari.
Support for adding custom properties to base DOM objects
Our goal is to avoid writing browser specific code within our application implementation. To accomplish 
this, our framework equalizes the object models and even extends built-in behavior by extending the 
prototypes of the base DOM objects. For example, we add properties to the base HTMLElement and 
Event objects.  Specifically, we have not found a way to do this in Opera.
Support for parsing and retrieving xml tags
We embed custom tags into our documents. These tags need to be properly parsed into their 
appropriate tree. For example, in the HTML document we may have tags such as:
<web:binding selector=".list" type="Demo.List"><web:defaults></web:defaults></web:binding>
We need to be able to query and extract these elements, their associated attributes, and any child 
elements.
 
These represent the typical requirements that have blocked us from running on a larger set of 
browsers. If you represent a browser that does not run Start.com, we would appreciate any help 
resolving these issues. You can reach me directly via the e-mail address startfb@microsoft.com. For the 
rest of you, we are working hard at enabling Start.com on the widest array of browsers and devices.
Comment 3 Alexey Proskuryakov 2005-11-20 08:55:18 PST
Duplicate of bug 4403?

The citation is apparently from <http://spaces.msn.com/members/siteexperts/Blog/cns!
1pNcL8JwTfkkjv4gg6LkVCpw!1925.entry>, which has some comments.
Comment 4 Robert 2005-11-20 10:10:37 PST
Created attachment 4742 [details]
Screenshot of Windows Live Mail in Safari
Comment 5 Robert 2005-11-20 10:11:31 PST
Created attachment 4743 [details]
Firefox Screenshot showing differences with safari.
Comment 6 Robert 2005-11-20 10:25:18 PST
Created attachment 4744 [details]
IE 6 on Windows XP using Windows Live Mail
Comment 7 Robert 2005-11-20 10:29:57 PST
Created attachment 4745 [details]
The Source Code for the page as shown by the 3 browser screenshots.
Comment 8 Robert 2005-11-20 10:33:53 PST
Created attachment 4746 [details]
javascript
Comment 9 Robert 2005-11-20 10:34:43 PST
Created attachment 4747 [details]
drag & drop script
Comment 10 Robert 2005-11-20 10:35:21 PST
Created attachment 4748 [details]
msnextras script
Comment 11 Robert 2005-11-20 10:35:47 PST
Created attachment 4749 [details]
msnlayout script
Comment 12 Sulka Haro 2005-12-05 05:49:56 PST
I think this is effectively a duplicate of http://bugzilla.opendarwin.org/show_bug.cgi?id=3565

Since the XMLHttpRequest POST support is broken, it effectively looks to most developers that AJAX is not 
supported.
Comment 13 David Kilzer (:ddkilzer) 2006-01-24 13:49:04 PST
Bug 6519 covers local.live.com.  Bug 6622 covers start.com.

Developers really need *specific* bugs (e.g., bugs on missing or incorrect JavaScript functionality) in order to make mail.live.com work with Safari, but this bug would work great as a meta-bug for tracking other bugs that must be fixed to make http://mail.live.com/ work in Safari.

I recommend the following changes:

1. Add the "HitListCandidate" keyword.
2. Change Summary to "mail.live.com does not work in Safari".

Is the author okay with this?
Comment 14 David Kilzer (:ddkilzer) 2006-01-29 08:24:48 PST
Changing this bug to be a tracking bug to make http://mail.live.com/ work with Safari per the original reporter's comments.  Changing Status to New per reporter's comments.   Changing Component to JavaScript for lack of a better category.

Need a test account for mail.live.com to do testing.  I believe that you must create a hotmail account first, then apply to be a beta tester.

User: webkit-test@hotmail.com
Pass: w3bk1t
Password reset question: First company you worked for
Password reset answer: Apple
Alternate e-mail address: webkit-unassigned@opendarwin.org
Name: Joe Webkit
Comment 15 David Kilzer (:ddkilzer) 2006-01-29 08:29:59 PST
Signed up webkit-test@hotmail.com as a Windows Live Mail beta tester through http://ideas.live.com/.  We now must wait for an invitation to be sent to webkit-test to join the beta unless someone else has an account already.
Comment 16 Jason Prell (superrcat) 2006-02-15 16:53:48 PST
I'm already a tester for Windows Live Mail and I am not having the problem described by the original poster, although the problem described was kind of vague. I will attach a screenshot of how it appears to render.
Comment 17 Jason Prell (superrcat) 2006-02-15 17:31:30 PST
Created attachment 6523 [details]
Windows Live Mail with Safari 2.0.3

Attaching a screenshot of Windows Live Mail as rendered by Safari 2.0.3.
Comment 18 David Kilzer (:ddkilzer) 2006-02-15 20:08:20 PST
(In reply to comment #16)
> I'm already a tester for Windows Live Mail and I am not having the problem
> described by the original poster, although the problem described was kind of
> vague. I will attach a screenshot of how it appears to render.

Great!  Do all of the features that you've tried work (not just that the page renders correctly, although that's a great start)?  Are there any error messages in the JavaScript Console (Cmd-Shift-J), accessible from the "Debug" menu in Safari?

In addition to Safari 2.0.3, have you tested the same features in the WebKit nightlies, too?
Comment 19 Jason Prell (superrcat) 2006-02-15 22:16:59 PST
All of the implemented features that appearing work fine. There are no Javascript messages appearing in the Console. I have also tested this with WebKit r12837 from 2006-02-16.

A message appearing on the "Welcome" tab within the web application states:

Is something missing? Read this.
We just started building this version of the Mail Beta that works for all browsers. We’re not done yet, so some functionality is missing right now. You can read your mail right now by clicking on the Inbox.
Note that the web browser you are using does not yet support all Mail Beta functionality. You can still use this browser to access basic Mail Beta functionality, like reading and composing messages. We will make more functionality available for this web browser soon.

The only way I could get the web application to not function as expected was by changing the User-Agent to Windows MSIE 6.0. At that point, rendering was atrocious and errors appeared in the Javascript Console:

Value undefined (result of expression s.b.addBehavior) is not object, Line 1

Value undefined (result of expression window.attachEvent) is not object, Line 736
http://by107w.bay107.mail.live.com/mail/11.00.0004.0079/fppclient.js

Undefined value, Line 218
http://by107w.bay107.mail.live.com/mail/11.00.0004.0079/MSNPlatform/msndragdrop.js

It doesn't appear that there is any javascript files included in the markup of the page when the User-Agent is set to Automatically Chosen.
Comment 20 Joost de Valk (AlthA) 2006-02-16 02:08:05 PST
Ok this is not our bug. Closing. (and INVALID doesn't mean you weren't right to file one)
Comment 21 David Kilzer (:ddkilzer) 2006-02-16 19:20:17 PST
Reopening so that this bug is marked RESOLVED/WORKSFORME since Comment #19 says the web site works fine without changing Safari's User Agent string.
Comment 22 David Kilzer (:ddkilzer) 2006-06-04 09:29:51 PDT
I'm reopening this bug because I just logged into the Windows Live Mail Beta and got dumped into "Classic Hotmail View" mode.  I think we want Safari to be able to use the full "Windows Live Mail Experience".

Please use this bug as a meta-bug and create separate bugs for each issue, and make them block this bug.

Here's the text of the note (similar to text from Comment #19):

You are using the Classic Hotmail View.
We’re not done building the Classic Hotmail View. Some functionality is not yet available. You can go to your inbox now or access the Windows Live Mail Experience.

How can you access the Windows Live Mail Experience?

• If you chose the Classic Hotmail View earlier: You can change your preference to the Windows Live Mail Experience. Windows Live Mail includes drag and drop, right click, and the reading pane to help you view your mail quickly.
• If you’re not using Internet Explorer 6.0: Using Internet Explorer versions 6.0 and higher will give you the best Windows Live Mail user experience with access to all functionality such as the reading pane and keyboard shortcuts. Internet Explorer 6.0 is available only for computers with certain system requirements.

• If you're using Firefox: You can now try the Windows Live Mail Experience with Firefox versions 1.5 and higher. Note that some Windows Live Mail Experience functionality is not yet available on Firefox.

Still not satisfied?

We are continuing to improve the Windows Live Mail experience. If you opt out of Windows Live Mail, you will return to MSN Hotmail. It may be difficult for you to return to the Windows Live Mail if you opt out now.
Comment 23 David Kilzer (:ddkilzer) 2006-06-04 09:41:15 PDT
Changing Safari's user agent to MSIE 6, the first error that appears in the JavaScript Console is:

TypeError: Value undefined (result of expression window.attachEvent) is not object.

This may be a red herring (like Bug 6622, Comment #0), but it should still be fixed.  Added bug 6598 as a dependency for tracking purposes.
Comment 24 Gavin Barraclough 2011-06-16 17:03:48 PDT
Works for me - I don't see the 'classic view' mentioned in the most recent comment.  Closing this bug since the most recent comments are 5 years old, and am not aware of any further issues with hotmail, but please reopen if I'm missing something here.