RESOLVED FIXED 56715
[Qt] Refactor handling of deferred loads
https://bugs.webkit.org/show_bug.cgi?id=56715
Summary [Qt] Refactor handling of deferred loads
Andreas Kling
Reported 2011-03-19 13:46:07 PDT
QNetworkReplyHandler is delicious spaghetti.
Attachments
Proposed patch (9.48 KB, patch)
2011-03-19 13:46 PDT, Andreas Kling
kenneth: review+
Proposed patch v2 (10.61 KB, patch)
2011-03-19 14:58 PDT, Andreas Kling
no flags
Andreas Kling
Comment 1 2011-03-19 13:46:42 PDT
Created attachment 86271 [details] Proposed patch
WebKit Review Bot
Comment 2 2011-03-19 13:50:10 PDT
Attachment 86271 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1 Source/WebCore/platform/network/qt/QNetworkReplyHandler.h:47: The parameter name "handle" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 1 in 4 files If any of these errors are false positives, please file a bug against check-webkit-style.
Kenneth Rohde Christiansen
Comment 3 2011-03-19 13:55:53 PDT
Comment on attachment 86271 [details] Proposed patch View in context: https://bugs.webkit.org/attachment.cgi?id=86271&action=review Generally looks good. All tests are passing I suppose :-) ? > Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:182 > + , m_deferStart(true) Shouldn't it be defers? > Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:184 > + , m_deferSendResponseIfNeeded(false) So what is ifNeeded? the defer or the send? tricky how to name these.
Kenneth Rohde Christiansen
Comment 4 2011-03-19 13:59:11 PDT
(In reply to comment #3) > (From update of attachment 86271 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=86271&action=review > > Generally looks good. All tests are passing I suppose :-) ? > > > Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:182 > > + , m_deferStart(true) > > Shouldn't it be defers? > > > Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:184 > > + , m_deferSendResponseIfNeeded(false) > > So what is ifNeeded? the defer or the send? tricky how to name these. Btw, I dislike the names loadSynchro.. Also it is not really a kind/mode anymore and it is either sync or async.
Kenneth Rohde Christiansen
Comment 5 2011-03-19 14:19:40 PDT
DataType { AsynchronousData, SynchronousData } ? just thinking here.
Andreas Kling
Comment 6 2011-03-19 14:58:03 PDT
Created attachment 86272 [details] Proposed patch v2 Updated patch with improved names. Also sprinkled some assertions over the code.
Benjamin Poulain
Comment 7 2011-03-19 15:08:33 PDT
Comment on attachment 86272 [details] Proposed patch v2 That looks good to me. I you have the courage to continue cleaning, it would be nice to make redirection a bit easier to understand. :) Maybe the constructor should be just calling init() so that the same init() could be called from the redirection called. This recycling of the current QNetworkReplyHandler is confusing :(
Andreas Kling
Comment 8 2011-03-19 15:15:27 PDT
Comment on attachment 86272 [details] Proposed patch v2 Clearing flags on attachment: 86272 Committed r81560: <http://trac.webkit.org/changeset/81560>
Andreas Kling
Comment 9 2011-03-19 15:15:34 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.