Bug 56291 - Could avoid add before checking RegisterFile::end
: Could avoid add before checking RegisterFile::end
Status: RESOLVED DUPLICATE of bug 124634
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To: Nobody
Depends on:
  Show dependency treegraph
Reported: 2011-03-13 23:29 PDT by Gavin Barraclough
Modified: 2013-11-19 22:30 PST (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Barraclough 2011-03-13 23:29:13 PDT
Could remove the add instruction in JIT code when checking RegisterFile end with a red-zone like approach.

E.g. remove RegisterFile::m_end, and replace it with a variable tracking something like RegisterFile::m_endMinus1k, for example - for most functions, this would ensure sufficient space is available, we'd only need to add before checking if the space required was greater than 1k.
Comment 1 Mark Lam 2013-11-19 22:30:00 PST
https://bugs.webkit.org/show_bug.cgi?id=124634 will take of this.

*** This bug has been marked as a duplicate of bug 124634 ***