Bug 56249 - (hash-replacestate) When a hash is set via location.hash then replaced via history.replaceState, history.back fails to go to the correct state
(hash-replacestate)
: When a hash is set via location.hash then replaced via history.replaceState, ...
Status: RESOLVED FIXED
: WebKit
History
: 528+ (Nightly build)
: Macintosh Intel Mac OS X 10.6
: P2 Normal
Assigned To:
: https://gist.github.com/867260
:
:
:
  Show dependency treegraph
 
Reported: 2011-03-12 06:21 PST by
Modified: 2011-03-14 11:03 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-03-12 06:21:33 PST
A reproducible demo file is here:
https://gist.github.com/867260

A screenflow of the problem is here:
http://www.youtube.com/watch?v=zO4z-gMYhp0

This bug is only in Safari 5, and not in Google Chrome.
------- Comment #1 From 2011-03-14 10:43:40 PST -------
Can you check this in nightly builds from http://nightly.webkit.org/? There have been quite a fix history changes between Safari 5 and the current Chrome stable channel build.
------- Comment #2 From 2011-03-14 11:01:24 PST -------
Correct Mihai, it's working fine (as expected) in the nightly: Version 5.0.4 (6533.20.27, r80833)

I'll be sure to check the nightlies next time before filing new bug reports :) Thanks!