Bug 56073 - REGRESSION(80478?): assertion failure m_suspended in WebCore::SuspendableTimer::resume() loading engadget.com and other sites
Summary: REGRESSION(80478?): assertion failure m_suspended in WebCore::SuspendableTime...
Status: RESOLVED DUPLICATE of bug 56062
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.engadget.com
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-09 22:17 PST by Alice Liu
Modified: 2011-03-10 11:06 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alice Liu 2011-03-09 22:17:22 PST
reproducibly hitting this assertion failure loading engadget.com, using WebKit2. Doesn't reproduce in MiniBrowser, though.  other sites are reproducing as well, like apple.com
 
1) use a WebKit2 browser window
2) load engadget.com

ASSERTION FAILED: m_suspended
/Volumes/Data/aliu/SourceGit/OpenSource/Source/WebCore/page/SuspendableTimer.cpp(76) : virtual void WebCore::SuspendableTimer::resume()
1   WebCore::SuspendableTimer::resume()
2   WebCore::ScriptExecutionContext::resumeActiveDOMObjects()
3   WebCore::Document::resumeScheduledTasks()
4   WebCore::FrameLoader::setDefersLoading(bool)
5   WebCore::Page::setDefersLoading(bool)
6   WebKit::WebPage::setDefersLoading(bool)
7   WKBundlePageSetDefersLoading

the regression range is 80473 (working) to 80494 (asserts).  

suspicious check-ins: http://trac.webkit.org/changeset/80478
Comment 1 Alexey Proskuryakov 2011-03-10 11:06:01 PST

*** This bug has been marked as a duplicate of bug 56062 ***