Bug 55970 - Cursor disappears from textarea on certain occasions.
Summary: Cursor disappears from textarea on certain occasions.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-08 14:40 PST by Cngevpxhaqrefpber
Modified: 2011-05-02 15:58 PDT (History)
8 users (show)

See Also:


Attachments
demo (216 bytes, text/html)
2011-03-09 11:45 PST, Ryosuke Niwa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cngevpxhaqrefpber 2011-03-08 14:40:12 PST
If you:

1. Set focus to a textarea with no text on it.

2. Type a bunch of characters (I was using spaces) until you get two characters from the right side edge/boundary of the textarea.

3. Type a letter (like 'a'), then press the space bar.

Then the cursor disappears in both Safari (latest version) and Google Chrome 10.0.648.127 (Official Build 76697), which doesn't seem right.

One thing I did notice is, if the textarea has a vertical scrollbar visible (I did this by inserting a bunch of empty lines) and you follow the same steps above, then the cursor does not disappear, _unless_ you're typing on the very last line of the textarea.
Comment 1 Ryosuke Niwa 2011-03-09 11:45:31 PST
Created attachment 85207 [details]
demo
Comment 2 Xiaomei Ji 2011-03-10 15:54:35 PST
might be the same cause as bug 49508 which I am working on.
looks like my fix fixes this issue as well.
Comment 3 Xiaomei Ji 2011-03-18 17:02:42 PDT

*** This bug has been marked as a duplicate of bug 49508 ***
Comment 4 Xiaomei Ji 2011-04-08 18:32:08 PDT
I am not so sure that this is a duplicate of bug 49508. The fix there fixed the problem in Safari in Mac, but not fixed for chromium Linux. There might be some other problems.
Comment 5 Ryosuke Niwa 2011-05-02 13:25:14 PDT
The caret / insertion point is rendered outside of the visible bound.

The related bugs: http://webkit.org/b/57745 and http://webkit.org/b/54598.
Comment 6 Enrica Casucci 2011-05-02 15:58:48 PDT
This has been fixed by http://trac.webkit.org/changeset/85535