Bug 55889 - Can't always scroll to see left overflow on RTL pages
Summary: Can't always scroll to see left overflow on RTL pages
Status: RESOLVED DUPLICATE of bug 55077
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: All OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://software.hixie.ch/utilities/js...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-07 11:45 PST by Simon Fraser (smfr)
Modified: 2011-03-09 14:15 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2011-03-07 11:45:35 PST
URL shows a testcase where you can't scroll to reveal left overflow on RTL pages.
Comment 1 mitz 2011-03-07 12:05:06 PST
Huh? <html style="direction:ltr">.
Comment 2 mitz 2011-03-07 12:05:54 PST
Meaning, that is not a right-to-left page (direction doesn’t propagate from <body> if it’s explicitly set on <html>).
Comment 3 Simon Fraser (smfr) 2011-03-07 12:15:57 PST
Updated URL.
Comment 4 Simon Fraser (smfr) 2011-03-07 12:16:59 PST
Caused by bug 55077?
Comment 5 mitz 2011-03-07 12:23:32 PST
Simon, the updated URL still has <html style="direction:ltr;">.
Comment 6 Simon Fraser (smfr) 2011-03-07 12:40:50 PST
Fixed.
Comment 7 mitz 2011-03-07 12:46:19 PST
Does seem like a duplicate of bug 55077.
Comment 8 Yair Yogev 2011-03-07 23:39:15 PST
i don't know which is correct but using the old URL (with <html style="direction:ltr"> but RTL body), FF showed a horizontal scrollbar while WebKit did not.
Comment 9 Xiaomei Ji 2011-03-08 09:22:59 PST
(In reply to comment #8)
> i don't know which is correct but using the old URL (with <html style="direction:ltr"> but RTL body), FF showed a horizontal scrollbar while WebKit did not.

The direction propagation in Webkit (when dir is set in root) is different from that in Firefox.

In Webkit "Direction and writing-mode should propagate from the <body> to the <html> to the ICB as long as the <html> hasn't explicitly set the direction or writing-mode." (from dhyatt),

while Firefox always propagate the direction from the <body> to the initial containing block even if the <html> has explicitly set the direction.

Please refer to description and comment #9 in bug 48157.
Comment 10 Xiaomei Ji 2011-03-08 22:54:10 PST
please reopen if I am wrong.

*** This bug has been marked as a duplicate of bug 55077 ***
Comment 11 Simon Fraser (smfr) 2011-03-09 07:54:09 PST
In this bug, we didn't even get a scrollbar.
Comment 12 Yair Yogev 2011-03-09 09:22:48 PST
(In reply to comment #11)
> In this bug, we didn't even get a scrollbar.


maybe i didn't understand the testcase, but after the change in comment #3 i get one (using chrome)
Comment 13 Xiaomei Ji 2011-03-09 14:09:51 PST
(In reply to comment #12)
> (In reply to comment #11)
> > In this bug, we didn't even get a scrollbar.
> 
> 
> maybe i didn't understand the testcase, but after the change in comment #3 i get one (using chrome)

Using chrome linux, I see the same: horizontal scrollbar presents. but scroll does not reveal left overflow before r80622, and it reveals left overflow after r80622.
Comment 14 Simon Fraser (smfr) 2011-03-09 14:15:44 PST
OK cool.

*** This bug has been marked as a duplicate of bug 55077 ***