Bug 5579 - WebKit+SVG renders full-filters-example incorrectly
Summary: WebKit+SVG renders full-filters-example incorrectly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P4 Normal
Assignee: Nobody
URL: http://www.w3.org/Graphics/SVG/Test/2...
Keywords: NeedsReduction
Depends on: 4462 4883 5526
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-01 02:45 PST by Eric Seidel (no email)
Modified: 2007-08-21 14:34 PDT (History)
1 user (show)

See Also:


Attachments
patch to fix the clipping problem (3.12 KB, patch)
2005-11-13 21:43 PST, Erick Tryzelaar
no flags Details | Formatted Diff | Diff
properly patching (4.08 KB, patch)
2005-11-13 21:57 PST, Erick Tryzelaar
eric: review-
Details | Formatted Diff | Diff
added MacDome's suggestions (5.45 KB, patch)
2005-11-13 22:56 PST, Erick Tryzelaar
no flags Details | Formatted Diff | Diff
hopefully final patch (5.40 KB, patch)
2005-11-13 23:14 PST, Erick Tryzelaar
no flags Details | Formatted Diff | Diff
expanded some tabs (5.41 KB, patch)
2005-11-13 23:15 PST, Erick Tryzelaar
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2005-11-01 02:45:58 PST
WebKit+SVG renders full-filters-example renderers incorrectly

This seems to a coordinates/clipping issue.
Comment 1 Eric Seidel (no email) 2005-11-01 02:47:42 PST
Erick is taking a crack at this one.
Comment 2 Erick Tryzelaar 2005-11-13 21:43:18 PST
Created attachment 4684 [details]
patch to fix the clipping problem

This should fix the clipping problem. So what happened is that the input image
was centered at 0,0, but it was supposed to be translated to the (x,y) of the
filter location. This should fix the problem.
Comment 3 Erick Tryzelaar 2005-11-13 21:57:42 PST
Created attachment 4685 [details]
properly patching
Comment 4 Eric Seidel (no email) 2005-11-13 22:26:07 PST
Comment on attachment 4685 [details]
properly patching

Erick and I talked about this over IRC.  One more round of patch cleanup is
necessary here.  Also, there seems to be a stray ASSERT.
Comment 5 Erick Tryzelaar 2005-11-13 22:56:58 PST
Created attachment 4686 [details]
added MacDome's suggestions
Comment 6 Erick Tryzelaar 2005-11-13 23:14:22 PST
Created attachment 4687 [details]
hopefully final patch
Comment 7 Erick Tryzelaar 2005-11-13 23:15:44 PST
Created attachment 4688 [details]
expanded some tabs
Comment 8 Eric Seidel (no email) 2005-11-13 23:23:39 PST
Comment on attachment 4688 [details]
expanded some tabs

Looks good.  r=me.  I'll land this early this week, hopefully as early as
tomorrow.
Comment 9 Eric Seidel (no email) 2005-11-26 14:38:07 PST
Comment on attachment 4688 [details]
expanded some tabs

Unfortunately this patch no longer applies cleanly after the big merger.  There
still need to be fixes in this area, however this patch is going to need to be
re-worked a bit now.  Best if we discuss this over IRC.  Removing the review
flag for now.
Comment 10 Eric Seidel (no email) 2005-12-06 04:46:17 PST
It actually does a very good job of rendering this example now in TOT, however there are still some 
clipping issues, which I believe are caused by rounding errors due to our use of ints:
http://bugzilla.opendarwin.org/show_bug.cgi?id=4462

Also, this example also suffers from the filter scaling problem:
http://bugzilla.opendarwin.org/show_bug.cgi?id=5526
Comment 11 Eric Seidel (no email) 2005-12-08 04:40:40 PST
The only thing left "wrong" is the grainyness:
http://bugzilla.opendarwin.org/show_bug.cgi?id=5526
Lack of Text:
http://bugzilla.opendarwin.org/show_bug.cgi?id=4883
And integer clipping:
http://bugzilla.opendarwin.org/show_bug.cgi?id=4462

I'm not sure that this bug serves a lot of use anymore.  But I'll leave it for now.
Comment 12 Nikolas Zimmermann 2007-08-21 14:34:18 PDT
Landed in r25175.