Bug 55318 - Crash logs aren't saved on Windows 7 when a relative --results-directory path is used (like on the test slaves)
: Crash logs aren't saved on Windows 7 when a relative --results-directory path...
Status: RESOLVED FIXED
: WebKit
Tools / Tests
: 528+ (Nightly build)
: PC Windows 7
: P2 Normal
Assigned To:
:
: PlatformOnly
:
: 44135
  Show dependency treegraph
 
Reported: 2011-02-27 09:18 PST by
Modified: 2011-02-27 09:30 PST (History)


Attachments
Ensure $testResultsDirectory is an absolute path before setting up Windows crash log saving (2.07 KB, patch)
2011-02-27 09:26 PST, Adam Roben (:aroben)
mitz: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-02-27 09:18:47 PST
Crash logs aren't saved on Windows 7 when a relative --results-directory path is used (like on the test slaves). Windows XP does not have this issue. The problem is due to a difference in how the post-mortem debugger is launched on these two OSes.

Windows XP: The post-mortem debugger is a child process of the crashing process, and its working directory matches the crashing process's.
Windows 7: The post-mortem debugger is a child process of WerFault.exe, and its working directory is c:\Windows\system32.

We save crash logs to a location relative to $testResultsDirectory in old-run-webkit-tests. When a relative path is passed to --results-directory, the path to the crash log file ends up being relative, too. Since the post-mortem debugger's working directory is c:\Windows\system32, the crash log file path gets resolved against that path, rather than getting resolved against old-run-webkit-tests working directory.
------- Comment #1 From 2011-02-27 09:26:37 PST -------
Created an attachment (id=83975) [details]
Ensure $testResultsDirectory is an absolute path before setting up Windows crash log saving
------- Comment #2 From 2011-02-27 09:30:25 PST -------
Committed r79819: <http://trac.webkit.org/changeset/79819>