Bug 55050 - [Qt] MinGW build fails to link
: [Qt] MinGW build fails to link
Status: RESOLVED DUPLICATE of bug 56723
: WebKit
Tools / Tests
: 528+ (Nightly build)
: PC Windows XP
: P1 Blocker
Assigned To:
:
: Qt, QtTriaged
:
: 50251
  Show dependency treegraph
 
Reported: 2011-02-23 08:35 PST by
Modified: 2011-03-23 19:22 PST (History)


Attachments
proposed patch (11.85 KB, patch)
2011-02-23 08:57 PST, Andras Becsi
no flags Review Patch | Details | Formatted Diff | Diff
proposed patch (10.60 KB, patch)
2011-02-23 09:20 PST, Andras Becsi
no flags Review Patch | Details | Formatted Diff | Diff
build log for linking (5.62 KB, text/plain)
2011-03-23 09:09 PST, Csaba Osztrogonác
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-02-23 08:35:32 PST
After the recent build system changes the MinGW linking fails with undefined reference errors. Apparently the compiler does not like the current library order.
------- Comment #1 From 2011-02-23 08:41:39 PST -------
This documentation says:
http://www.network-theory.co.uk/docs/gccintro/gccintro_18.html

"Most current linkers will search all libraries, regardless of order, but since some do not do this it is best to follow the convention of ordering libraries from left to right."

The problem win-gcc has is that the webcore and jscore libraries are after the windows libraries in the build command line, so there are unresolved symbols.
------- Comment #2 From 2011-02-23 08:57:08 PST -------
Created an attachment (id=83488) [details]
proposed patch

I don't set r?, so Laszlo can check whether it works on Symbian, Ossy already shut down our Windows bots.
------- Comment #3 From 2011-02-23 09:20:46 PST -------
Created an attachment (id=83490) [details]
proposed patch

Fix the final linking order to be webkit2 webcore jscore.
------- Comment #4 From 2011-02-23 20:56:32 PST -------
(In reply to comment #3)
> Created an attachment (id=83490) [details] [details]
> proposed patch
> 
> Fix the final linking order to be webkit2 webcore jscore.

No regression on Symbian build from this patch. Patch looks good to me, please put it up for review.
------- Comment #5 From 2011-02-24 02:06:46 PST -------
(From update of attachment 83490 [details])
Thanks, Laszlo, for checking.
------- Comment #6 From 2011-02-24 04:49:35 PST -------
(From update of attachment 83490 [details])
Looks good to me, r+.
------- Comment #7 From 2011-02-24 05:57:05 PST -------
Landed in http://trac.webkit.org/changeset/79548.
Closing bug.
------- Comment #8 From 2011-02-24 05:57:33 PST -------
(From update of attachment 83490 [details])
Clearing flags.
------- Comment #9 From 2011-03-23 09:07:41 PST -------
Reopen, because it still fails with MinGW on Windows. (But works with cross-MinGW on Linux - with same MinGW version)
------- Comment #10 From 2011-03-23 09:09:12 PST -------
Created an attachment (id=86626) [details]
build log for linking
------- Comment #11 From 2011-03-23 19:22:26 PST -------
I prefer to close this as DUP as the other bug was opened earlier for MingW on Windows (even though that bug has a higher bug id). There is also some good progress on resolving this on the other bug.

*** This bug has been marked as a duplicate of bug 56723 ***