Bug 55045 - fast/dom/52776.html sometimes crashes on Windows
: fast/dom/52776.html sometimes crashes on Windows
Status: RESOLVED WORKSFORME
Product: WebKit
Classification: Unclassified
Component: Text
: 528+ (Nightly build)
: PC Windows 7
: P2 Normal
Assigned To: Nobody
: InRadar, LayoutTestFailure, MakingBotsRed, PlatformOnly
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 08:12 PST by Adam Roben (:aroben)
Modified: 2011-03-18 14:21 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2011-02-23 08:12:46 PST
fast/dom/52776.html sometimes crashes on Windows. Here's an example:

Did not crash: <http://build.webkit.org/builders/Windows%207%20Release%20%28Tests%29/builds/9675>
Did crash: <http://build.webkit.org/builders/Windows%207%20Release%20%28Tests%29/builds/9676>
Comment 1 Adam Roben (:aroben) 2011-02-23 09:06:17 PST
<rdar://problem/9042191>
Comment 2 mitz@webkit.org 2011-02-23 09:18:38 PST
What is the crash backtrace?
Comment 3 Adam Roben (:aroben) 2011-02-23 09:21:59 PST
(In reply to comment #2)
> What is the crash backtrace?

I don't know. The Windows 7 bots don't record backtraces due to bug 44135, and I haven't been able to reproduce the crash so far.
Comment 4 Adam Roben (:aroben) 2011-02-23 09:24:37 PST
…and I haven't seen the crash on the XP bots.
Comment 5 Xiaomei Ji 2011-02-23 10:00:24 PST
I checked the assertion introduced in r76319, and I did not see problem there.
(If it is wrong, it should be hit in all platforms).

I never tried to compile WebKit in Windows since I have Visual Studio 2008.
Is it compilable against VS2008? Any instruction page?
Comment 6 Adam Roben (:aroben) 2011-02-23 11:38:48 PST
(In reply to comment #5)
> I checked the assertion introduced in r76319, and I did not see problem there.
> (If it is wrong, it should be hit in all platforms).
> 
> I never tried to compile WebKit in Windows since I have Visual Studio 2008.
> Is it compilable against VS2008? Any instruction page?

Most people use VS2005. I don't know if VS2008 will work.
Comment 7 Adam Roben (:aroben) 2011-03-18 14:21:26 PDT
I haven't seen this happen in many weeks. Maybe this test was a victim of some other test misbehaving.