Bug 55037 - Add support to Python 3 for webkit-patch
Summary: Add support to Python 3 for webkit-patch
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P3 Enhancement
Assignee: Nobody
URL:
Keywords:
: 71170 71723 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-23 04:36 PST by Benjamin Poulain
Modified: 2014-10-04 13:08 PDT (History)
5 users (show)

See Also:


Attachments
Patch (26.48 KB, patch)
2011-02-24 12:08 PST, Benjamin Poulain
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2011-02-23 04:36:59 PST
Python 3 is the default for some Linux distribution. It would be nice to support it for webkit-tools.

Python 2.5 is the minimum version we must support: https://lists.webkit.org/pipermail/webkit-dev/2011-February/016032.html
Comment 1 Benjamin Poulain 2011-02-24 11:51:52 PST
Unfortunately, we rely on third party that do not support Python 3 yet (mechanize for example). So that will have to wait a bit.
Comment 2 Benjamin Poulain 2011-02-24 12:08:05 PST
Created attachment 83693 [details]
Patch
Comment 3 Benjamin Poulain 2011-02-24 12:11:40 PST
Comment on attachment 83693 [details]
Patch

This patch does not make any feature available with Python 3. I am blocked by the lib "mechanize" which is not compatible.

I put the patch here so the work is not lost.
Comment 4 Eric Seidel (no email) 2011-11-05 16:26:00 PDT
*** Bug 71170 has been marked as a duplicate of this bug. ***
Comment 5 Eric Seidel (no email) 2011-11-05 16:28:09 PDT
We just upgraded our copy of Mechanize.  Perhaps its python 3 compatible now? bug 71594.
Comment 6 Eric Seidel (no email) 2011-11-07 13:13:14 PST
*** Bug 71723 has been marked as a duplicate of this bug. ***
Comment 7 Benjamin Poulain 2011-11-22 23:21:52 PST
(In reply to comment #5)
> We just upgraded our copy of Mechanize.  Perhaps its python 3 compatible now? bug 71594.

I had a quick look at Mechanize, and it does not look like it supports Python 3. We should probably port it ourself if many people use Python 3.

I fall back on Python 2 for webkit-patch.