Bug 54801 - Make WinCE a core builder
Summary: Make WinCE a core builder
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Patrick R. Gansterer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-19 04:29 PST by Patrick R. Gansterer
Modified: 2011-02-21 09:56 PST (History)
3 users (show)

See Also:


Attachments
Patch (1.94 KB, patch)
2011-02-19 04:30 PST, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick R. Gansterer 2011-02-19 04:29:37 PST
Make WinCE a core builder
Comment 1 Patrick R. Gansterer 2011-02-19 04:30:44 PST
Created attachment 83070 [details]
Patch
Comment 2 Patrick R. Gansterer 2011-02-19 04:35:22 PST
Most of the people don't care about non-core builders, so make WinCE one.
WinCE was only red, when people broke it. I didn't see any problem with the machine since it's online.
Comment 3 Andreas Kling 2011-02-19 05:20:07 PST
Comment on attachment 83070 [details]
Patch

r=me, let's see how this goes! :)
Comment 4 WebKit Commit Bot 2011-02-19 07:17:41 PST
Comment on attachment 83070 [details]
Patch

Clearing flags on attachment: 83070

Committed r79120: <http://trac.webkit.org/changeset/79120>
Comment 5 WebKit Commit Bot 2011-02-19 07:17:46 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Adam Barth 2011-02-19 11:41:32 PST
Scrolling back though the history of <http://build.webkit.org/builders/WinCE%20Release%20%28Build%29> this morning, the builder appears to be red more often than its green.  We'd like core builders to be green much more often than they're red.  Hopefully the builder will remain green in the future.
Comment 7 Patrick R. Gansterer 2011-02-19 11:46:45 PST
(In reply to comment #6)
> Scrolling back though the history of <http://build.webkit.org/builders/WinCE%20Release%20%28Build%29> this morning, the builder appears to be red more often than its green.  We'd like core builders to be green much more often than they're red.  Hopefully the builder will remain green in the future.

I've been one week on vacation and didn't fixed the build problems. That's also the reason why I didn't created this patch earlier. IMHO the problem is that most of the people don't care about non core builder.
Comment 8 Adam Barth 2011-02-19 11:55:18 PST
Ok.  My point is more that being a core builder is descriptive rather than proscriptive.  They're not intended to force people to care about a particular builder.  They're intended to describe which builders people care about.

In any case, it's purely an empirical list.  If the builder remains green, no problem.  If the builder is often red, then we can remove it from the list.

Note: You'll need to ask wms to restart the buildbot master so that the bot shows up on the core builder page.
Comment 9 Patrick R. Gansterer 2011-02-19 12:05:13 PST
(In reply to comment #8)
> Ok.  My point is more that being a core builder is descriptive rather than proscriptive.  They're not intended to force people to care about a particular builder.  They're intended to describe which builders people care about.

When you get responses like "ohh, WinCE has a buildbot?", it seams to me that many people don't know about working non core builder. See also the "At times, people have mentioned to me that they left a failure in only because the bot is non-core and they didn't notice." from mjs in https://lists.webkit.org/pipermail/webkit-dev/2011-February/015894.html

> In any case, it's purely an empirical list.  If the builder remains green, no problem.  If the builder is often red, then we can remove it from the list.

So let's try it. :-)
Comment 10 Adam Barth 2011-02-19 12:07:32 PST
> So let's try it. :-)

Yep.  :)
Comment 11 William Siegrist 2011-02-21 09:56:27 PST
Buildbot master updated.