Bug 54647 - Transitioning between transform:translate() with different units doesn't work
: Transitioning between transform:translate() with different units doesn't work
Status: RESOLVED DUPLICATE of bug 23775
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: Macintosh Intel Mac OS X 10.6
: P2 Normal
Assigned To: Nobody
http://oli.jp/bugs/browser/transform-...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-17 06:23 PST by Oli Studholme
Modified: 2011-06-06 21:09 PDT (History)
3 users (show)

See Also:


Attachments
Testcase (2.81 KB, text/html)
2011-02-17 10:37 PST, Simon Fraser (smfr)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oli Studholme 2011-02-17 06:23:22 PST
When transitioning between two transform:translate() values, the transition only works correctly if both pre- and post-transition translate states use the same length units.
* In WebKit Version 5.0.3 (6533.19.4, r78685) & Safari Version 5.0.3 (6533.19.4) when the transform:translate() units differ and the transition is stopped before completing, the transition jumps to the end translate state before reverting at a higher speed to finish at the correct time
* In Chrome 9.0.597.102 (and Opera 11.01) if transform:translate() length units differ (initial = px, :hover = %), then the change is instant and the transition is ignored.
* Firefox 4 beta 8 gets a gold star for rendering as expected
http://oli.jp/bugs/browser/transform-translate.html
Comment 1 Simon Fraser (smfr) 2011-02-17 10:37:16 PST
Created attachment 82830 [details]
Testcase
Comment 2 Simon Fraser (smfr) 2011-02-17 10:37:38 PST
I see different behavior with and without accelerated compositing enabled.
Comment 3 Simon Fraser (smfr) 2011-06-06 21:00:14 PDT
(In reply to comment #2)
> I see different behavior with and without accelerated compositing enabled.

Actually that's not true. This is related to interrupted transitions.
Comment 4 Simon Fraser (smfr) 2011-06-06 21:09:15 PDT
This is expected for now. We don't have the smarts to convert both endpoints to the same units before transitioning.
Comment 5 Simon Fraser (smfr) 2011-06-06 21:09:49 PDT

*** This bug has been marked as a duplicate of bug 23775 ***