Bug 54481 - Add NPP_GetSitesWithData and NPP_URLRedirectNotify to the NPAPI headers
Summary: Add NPP_GetSitesWithData and NPP_URLRedirectNotify to the NPAPI headers
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-15 11:53 PST by Anders Carlsson
Modified: 2011-02-15 12:51 PST (History)
1 user (show)

See Also:


Attachments
Patch (9.59 KB, patch)
2011-02-15 11:57 PST, Anders Carlsson
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2011-02-15 11:53:13 PST
Add NPP_GetSitesWithData and NPP_URLRedirectNotify to the NPAPI headers
Comment 1 Anders Carlsson 2011-02-15 11:57:06 PST
Created attachment 82493 [details]
Patch
Comment 2 WebKit Review Bot 2011-02-15 11:58:35 PST
Attachment 82493 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1

Source/WebCore/bridge/nptypes.h:39:  #ifndef header guard has wrong style, please use: WTF_nptypes_h  [build/header_guard] [5]
Source/WebCore/bridge/nptypes.h:56:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Source/WebCore/bridge/nptypes.h:57:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Source/WebCore/bridge/nptypes.h:57:  uint64_t is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/bridge/nptypes.h:82:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Source/WebCore/bridge/nptypes.h:82:  uint64_t is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/bridge/npapi.h:241:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Source/WebCore/bridge/npapi.h:242:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Source/WebCore/bridge/npapi.h:825:  The parameter name "direction" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/bridge/npapi.h:825:  Extra space between NPBool and NP_LOADDS  [whitespace/declaration] [3]
Source/WebCore/bridge/npapi.h:826:  Extra space between void and NP_LOADDS  [whitespace/declaration] [3]
Source/WebCore/bridge/npapi.h:827:  Extra space between void and NP_LOADDS  [whitespace/declaration] [3]
Source/WebCore/bridge/npapi.h:829:  Extra space between char** and NP_LOADDS  [whitespace/declaration] [3]
Total errors found: 13 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Darin Adler 2011-02-15 12:18:56 PST
Comment on attachment 82493 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=82493&action=review

>> Source/WebCore/bridge/npapi.h:241
>> +  NPFocusNext = 0,
> 
> Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]

Need to tell the style bot this file is not in our style.
Comment 4 Anders Carlsson 2011-02-15 12:51:01 PST
Committed r78604: <http://trac.webkit.org/changeset/78604>