Bug 5443 - REGRESSION highlight left behind when contracting a selection
Summary: REGRESSION highlight left behind when contracting a selection
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P1 Normal
Assignee: Dave Hyatt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-20 09:03 PDT by mitz
Modified: 2005-10-21 11:14 PDT (History)
0 users

See Also:


Attachments
compute highlight width correctly (1.22 KB, patch)
2005-10-20 09:46 PDT, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2005-10-20 09:03:55 PDT
The selection highlight is not repainted correctly when contracting the selection by dragging its end.

To reproduce: drag across a line of text on this page from left to right and all the way back, starting the 
selection anywhere *after* the first character.

I think this also comes from the latest changes to WebTextRenderer.m (r1.198 or r1.197).

Looks like the editing/selection/fake-drag pixel-test detects this regression.
Comment 1 mitz 2005-10-20 09:46:17 PDT
Created attachment 4422 [details]
compute highlight width correctly

This patch also fixes the regression where the drag image for selections that
don't start at character 0 was incorrect.
Comment 2 Darin Adler 2005-10-20 14:16:40 PDT
Comment on attachment 4422 [details]
compute highlight width correctly

Oops! Thanks. Sorry.