RESOLVED FIXED 54421
Add initial support for per-origin quotas to IndexedDB
https://bugs.webkit.org/show_bug.cgi?id=54421
Summary Add initial support for per-origin quotas to IndexedDB
Jeremy Orlow
Reported 2011-02-14 16:28:14 PST
Add initial support for per-origin quotas to IndexedDB
Attachments
Patch (12.32 KB, patch)
2011-02-14 16:33 PST, Jeremy Orlow
no flags
Patch (12.33 KB, patch)
2011-02-15 12:56 PST, Jeremy Orlow
fishd: review+
fishd: commit-queue-
Jeremy Orlow
Comment 1 2011-02-14 16:33:26 PST
Jeremy Orlow
Comment 2 2011-02-14 16:42:40 PST
please review
Jeremy Orlow
Comment 3 2011-02-14 16:42:57 PST
+ darin for api change
Hans Wennborg
Comment 4 2011-02-15 02:35:54 PST
Comment on attachment 82381 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=82381&action=review > Source/WebCore/storage/IDBFactoryBackendImpl.cpp:265 > + m_currentQuotaMap.set(fileIdentifier, maximumSize); nit: Indented one space too much? > Source/WebCore/storage/IDBFactoryBackendImpl.h:70 > + typedef HashMap<String, int64_t> Quota; hmm, could it be called QuotaMap or something instead? just "Quota" makes me think of a scalar... lgtm
Jeremy Orlow
Comment 5 2011-02-15 12:56:48 PST
Darin Fisher (:fishd, Google)
Comment 6 2011-02-15 14:00:36 PST
Comment on attachment 82509 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=82509&action=review > Source/WebKit/chromium/public/WebIDBFactory.h:60 > + static const long long DefaultQuota = -1; nit: use variable naming: fooBar maybe these variables should be named differently so that it is more apparent that they should be passed in for the "maximumSize" field? how about renaming maximumSize to quota? alternatively, you could rename the constants to defaultMaximumSize and unlimitedMaximumSize. also, since this expression of quota might appear in other WebKit storage APIs, maybe we should have some generalized expression of quota? maybe these constants should be pulled out to a separate header file?
Jeremy Orlow
Comment 7 2011-02-15 15:44:26 PST
(In reply to comment #6) > (From update of attachment 82509 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=82509&action=review > > > Source/WebKit/chromium/public/WebIDBFactory.h:60 > > + static const long long DefaultQuota = -1; > > nit: use variable naming: fooBar done > maybe these variables should be named differently so that it is more apparent > that they should be passed in for the "maximumSize" field? > > how about renaming maximumSize to quota? alternatively, you could rename the > constants to defaultMaximumSize and unlimitedMaximumSize. renamed to quota and defaultQuota > also, since this expression of quota might appear in other WebKit storage APIs, > maybe we should have some generalized expression of quota? maybe these constants > should be pulled out to a separate header file? This seems a bit premature, but I will add a fixme and I've cc'ed others who are involved in Chromium quota stuff as a FYI.
Jeremy Orlow
Comment 8 2011-02-15 16:38:17 PST
Note You need to log in before you can comment on or make changes to this bug.