Bug 54386 - [GTK] Crashes after r78451, added built-in decoder for UTF-8
Summary: [GTK] Crashes after r78451, added built-in decoder for UTF-8
Status: RESOLVED DUPLICATE of bug 53898
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 54382 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-14 04:17 PST by Alejandro G. Castro
Modified: 2011-02-14 09:54 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro G. Castro 2011-02-14 04:17:25 PST
Apparently some tests are hiting assertions:

http://webkit-bots.igalia.com/amd64/svn_78458.core-when_1297677236-_-who_DumpRenderTree-_-why_11.trace.html

#0  0x00007f90dbe36c29 in WTF::StringBuffer::shrink (this=0x7fffc5173760, newLength=2) at ../../Source/JavaScriptCore/wtf/text/StringBuffer.h:56
56	        ASSERT(newLength <= m_length);

#0  0x00007f90dbe36c29 in WTF::StringBuffer::shrink (this=0x7fffc5173760, newLength=2) at ../../Source/JavaScriptCore/wtf/text/StringBuffer.h:56
#1  0x00007f90dc2dd535 in WebCore::TextCodecUTF8::decode (this=0x1699de0, bytes=0x7fffc51738c8 "\200", length=1, flush=true, stopOnError=false, sawError=@0x7fffc517386f) at ../../Source/WebCore/platform/text/TextCodecUTF8.cpp:313
#2  0x00007f90dc2ddc77 in WebCore::TextEncoding::decode (this=0x7f90de39ae70, data=0x7fffc51738c8 "\200", length=1, stopOnError=false, sawError=@0x7fffc517386f) at ../../Source/WebCore/platform/text/TextEncoding.cpp:71
#3  0x00007f90dc05efbe in WebCore::TextEncoding::decode (this=0x7f90de39ae70, str=0x7fffc51738c8 "\200", length=1) at ../../Source/WebCore/platform/text/TextEncoding.h:69
#4  0x00007f90dc299f90 in WebCore::decodeURLEscapeSequences (str=..., encoding=...) at ../../Source/WebCore/platform/KURL.cpp:947
#5  0x00007f90dc299d3c in WebCore::decodeURLEscapeSequences (str=...) at ../../Source/WebCore/platform/KURL.cpp:909
#6  0x00007f90dc05cc68 in WebCore::(anonymous namespace)::decodeURL (string=..., encoding=...) at ../../Source/WebCore/html/parser/XSSFilter.cpp:115

And also we can find:

http://webkit-bots.igalia.com/amd64/svn_78458.core-when_1297677247-_-who_DumpRenderTree-_-why_11.trace.html

#0  0x00007f550ed24f75 in WebCore::TextCodecUTF8::decode (this=0x2910a60, bytes=0x0, length=0, flush=true, stopOnError=false, sawError=@0x29dd004) at ../../Source/WebCore/platform/text/TextCodecUTF8.cpp:217
217	            ASSERT(count > m_partialSequenceSize);


Thread 1 (Thread 12916):
#0  0x00007f550ed24f75 in WebCore::TextCodecUTF8::decode (this=0x2910a60, bytes=0x0, length=0, flush=true, stopOnError=false, sawError=@0x29dd004) at ../../Source/WebCore/platform/text/TextCodecUTF8.cpp:217
#1  0x00007f550ebd8dab in WebCore::TextResourceDecoder::flush (this=0x29dcfb0) at ../../Source/WebCore/loader/TextResourceDecoder.cpp:687
#2  0x00007f550f04c41d in WebCore::XMLHttpRequest::didFinishLoading (this=0x29d5390, identifier=502) at ../../Source/WebCore/xml/XMLHttpRequest.cpp:999
#3  0x00007f550eb82789 in WebCore::DocumentThreadableLoader::didFinishLoading (this=0x2980700, identifier=502) at ../../Source/WebCore/loader/DocumentThreadableLoader.cpp:248
#4  0x00007f550eb831ab in WebCore::DocumentThreadableLoader::loadRequest (this=0x2980700, request=..., securityCheck=WebCore::DoSecurityCheck) at ../../Source/WebCore/loader/DocumentThreadableLoader.cpp:362
#5  0x00007f550eb8121d in WebCore::DocumentThreadableLoader::DocumentThreadableLoader (this=0x2980700, document=0x2965f60, client=0x29d53a0, blockingBehavior=WebCore::DocumentThreadableLoader::LoadSynchronously, request=..., options=...) at ../../Source/WebCore/loader/DocumentThreadableLoader.cpp:76
#6  0x00007f550eb808fc in WebCore::DocumentThreadableLoader::loadResourceSynchronously (document=0x2965f60, request=..., client=..., options=...) at ../../Source/WebCore/loader/DocumentThreadableLoader.cpp:53
Comment 2 Alejandro G. Castro 2011-02-14 04:32:52 PST
Rolled out the patch: http://trac.webkit.org/changeset/78465
Comment 3 Alejandro G. Castro 2011-02-14 04:33:49 PST
Duplicating after the reopening of the original bug.

*** This bug has been marked as a duplicate of bug 53898 ***
Comment 4 Alexey Proskuryakov 2011-02-14 08:53:56 PST
*** Bug 54382 has been marked as a duplicate of this bug. ***
Comment 5 Darin Adler 2011-02-14 09:54:34 PST
Really strange to mark this as a duplicate of the new encoder bug itself. I don’t understand how you folks use bugs.webkit.org.