Bug 54375 - [Chromium] REGRESSION(r77370): Wrong right offset for RTL popup
Summary: [Chromium] REGRESSION(r77370): Wrong right offset for RTL popup
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-13 23:26 PST by Naoki Takano
Modified: 2011-02-14 05:12 PST (History)
3 users (show)

See Also:


Attachments
Patch (7.42 KB, patch)
2011-02-13 23:31 PST, Naoki Takano
no flags Details | Formatted Diff | Diff
Patch (7.51 KB, patch)
2011-02-14 00:23 PST, Naoki Takano
no flags Details | Formatted Diff | Diff
Patch (7.50 KB, patch)
2011-02-14 00:27 PST, Naoki Takano
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Naoki Takano 2011-02-13 23:26:51 PST
[Chromium] Fix wrong popup position for RTL(again)
Comment 1 Naoki Takano 2011-02-13 23:31:25 PST
Created attachment 82288 [details]
Patch
Comment 2 Naoki Takano 2011-02-13 23:33:13 PST
Could you review again?

As I wrote ChangeLog, the bug is introduced by previous RTL fix and not good for the fix http://codereview.chromium.org/6024008/.
Comment 3 Kent Tamura 2011-02-13 23:48:08 PST
Comment on attachment 82288 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=82288&action=review

> Source/WebCore/ChangeLog:8
> +        No new tests. (OOPS!)

Please remove this line.

> Source/WebCore/ChangeLog:15
> +        (WebCore::PopupContainer::layoutAndCalculateWidgetRect): Change the input parameter to take |popupInitialCoordinate| again. And calculate correct right position with returned right offset from layoutAndRightOffset().

We don't use the || notation in WebKit.  Please remove it.

> Source/WebCore/ChangeLog:17
> +        (WebCore::PopupContainer::layoutAndRightOffset): Change the name from layout() and to return |rightOffset| value.

ditto.

> Source/WebCore/platform/chromium/PopupMenuChromium.cpp:351
> +        // Use |popupInitialCoordinate.x()| + |rightOffset| because RTL position

ditto.

> Source/WebCore/platform/chromium/PopupMenuChromium.cpp:415
> +int PopupContainer::layoutAndRightOffset()

The name layoutAndRightOffset() looks curious.  Maybe layoutAndGetRightOffset() is better?
Comment 4 Naoki Takano 2011-02-14 00:23:47 PST
Created attachment 82293 [details]
Patch
Comment 5 Naoki Takano 2011-02-14 00:24:09 PST
Comment on attachment 82293 [details]
Patch

Please review again.
Comment 6 Naoki Takano 2011-02-14 00:24:34 PST
Oops, just a moment.

(In reply to comment #5)
> (From update of attachment 82293 [details])
> Please review again.
Comment 7 Kent Tamura 2011-02-14 00:25:54 PST
Comment on attachment 82293 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=82293&action=review

> Source/WebCore/platform/chromium/PopupMenuChromium.cpp:351
> +        // Use |popupInitialCoordinate.x()| + |rightOffset| because RTL position

Please remove ||||.
Comment 8 Naoki Takano 2011-02-14 00:27:35 PST
Created attachment 82294 [details]
Patch
Comment 9 Naoki Takano 2011-02-14 00:28:04 PST
Comment on attachment 82294 [details]
Patch

Deleted || notation. Please review.
Comment 10 WebKit Commit Bot 2011-02-14 05:12:11 PST
Comment on attachment 82294 [details]
Patch

Clearing flags on attachment: 82294

Committed r78467: <http://trac.webkit.org/changeset/78467>
Comment 11 WebKit Commit Bot 2011-02-14 05:12:16 PST
All reviewed patches have been landed.  Closing bug.