Bug 54350 - [Gtk] WebView.h: No such file or directory
: [Gtk] WebView.h: No such file or directory
Status: RESOLVED DUPLICATE of bug 52805
: WebKit
WebKit Gtk
: 528+ (Nightly build)
: PC Linux
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-02-13 01:13 PST by
Modified: 2011-02-20 13:09 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-02-13 01:13:17 PST
after

make distclean
svn update
./autogen.sh --enable-web-sockets --enable-geolocation --enable-3D-transforms --enable-filters --enable-webkit2
make

after many hours of compilations, I get:

  CXX    Source/WebKit2/UIProcess/API/C/gtk/libWebKit2_la-WKView.lo
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp:32:21: error: WebView.h: No such file or directory
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp: In function ‘const OpaqueWKView* WKViewCreate(GdkRectangle, const OpaqueWKContext*, const OpaqueWKPageGroup*)’:
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp:42: error: incomplete type ‘WebKit::WebView’ used in nested name specifier
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp: In function ‘GtkWidget* WKViewGetWindow(const OpaqueWKView*)’:
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp:48: error: invalid use of incomplete type ‘struct WebKit::WebView’
./Source/WebKit2/UIProcess/API/C/gtk/WKAPICastGtk.h:36: error: forward declaration of ‘struct WebKit::WebView’
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp: In function ‘const OpaqueWKPage* WKViewGetPage(const OpaqueWKView*)’:
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp:53: error: invalid use of incomplete type ‘struct WebKit::WebView’
./Source/WebKit2/UIProcess/API/C/gtk/WKAPICastGtk.h:36: error: forward declaration of ‘struct WebKit::WebView’
In file included from ./Source/JavaScriptCore/wtf/CrossThreadRefCounted.h:35,
                 from ./Source/JavaScriptCore/wtf/text/StringImpl.h:28,
                 from ./Source/JavaScriptCore/wtf/text/WTFString.h:28,
                 from ./Source/WebCore/platform/text/PlatformString.h:28,
                 from ./Source/WebCore/platform/network/ResourceErrorBase.h:29,
                 from ./Source/WebCore/platform/network/soup/ResourceError.h:29,
                 from ./DerivedSources/WebKit2/include/WebCore/ResourceError.h:1,
                 from ./Source/WebKit2/Shared/WebError.h:30,
                 from ./Source/WebKit2/Shared/API/c/WKSharedAPICast.h:38,
                 from ./Source/WebKit2/UIProcess/API/C/WKAPICast.h:37,
                 from Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp:31:
./Source/JavaScriptCore/wtf/PassRefPtr.h: In function ‘void WTF::derefIfNotNull(T*) [with T = WebKit::WebView]’:
./Source/JavaScriptCore/wtf/RefPtr.h:58:   instantiated from ‘WTF::RefPtr<T>::~RefPtr() [with T = WebKit::WebView]’
Source/WebKit2/UIProcess/API/C/gtk/WKView.cpp:42:   instantiated from here
./Source/JavaScriptCore/wtf/PassRefPtr.h:59: error: invalid use of incomplete type ‘struct WebKit::WebView’
./Source/WebKit2/UIProcess/API/C/gtk/WKAPICastGtk.h:36: error: forward declaration of ‘struct WebKit::WebView’
make[1]: *** [Source/WebKit2/UIProcess/API/C/gtk/libWebKit2_la-WKView.lo] Error 1
make[1]: Leaving directory `/home/marina/src/WebKit'
make: *** [all] Error 2

-------------------------------------------------------------------------
Environment: Fedora 13
svn info
Path: .
URL: http://svn.webkit.org/repository/webkit/trunk
Repository Root: http://svn.webkit.org/repository/webkit
Repository UUID: 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Revision: 78421
Node Kind: directory
Schedule: normal
Last Changed Author: abarth@webkit.org
Last Changed Rev: 78421
Last Changed Date: 2011-02-12 13:35:25 -0800 (Sat, 12 Feb 2011)
------- Comment #1 From 2011-02-15 13:58:55 PST -------
I'm not sure if WebKit2 is compiling at the moment. I've CC'd Alex, who has a much better understanding of the current state of WebKit2 than I do.
------- Comment #2 From 2011-02-15 23:36:06 PST -------
(In reply to comment #0)
> after
> 
> make distclean
> svn update
> ./autogen.sh --enable-web-sockets --enable-geolocation --enable-3D-transforms --enable-filters --enable-webkit2
> make
> 

The patch that adds that file is still being reviewed. We are just starting to add the first code to make webkit2 work with gtk+, you can follow the advances in the bug 52805. Meanwhile compilation will not work. Hopefully these weeks we can have the initial code uploaded.

*** This bug has been marked as a duplicate of bug 52805 ***
------- Comment #3 From 2011-02-20 13:09:32 PST -------
*** Bug 54819 has been marked as a duplicate of this bug. ***