Bug 54088 - Opening GMail compose window distorts fonts due to Flash plugin
Summary: Opening GMail compose window distorts fonts due to Flash plugin
Status: RESOLVED DUPLICATE of bug 23364
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-09 03:58 PST by Ismail Donmez
Modified: 2011-02-25 08:48 PST (History)
1 user (show)

See Also:


Attachments
Fonts before I click on compose window (19.56 KB, image/png)
2011-02-09 03:58 PST, Ismail Donmez
no flags Details
Font distortion with compose window open (18.93 KB, image/png)
2011-02-09 03:59 PST, Ismail Donmez
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ismail Donmez 2011-02-09 03:58:07 PST
This is a weird bug, to reproduce you must have Flash Plugin 10.1 or later installed.

How to reproduce:

- Open your GMail inbox
- Notice that all fonts are good and antialiased
- Click compose window
- Note that fonts become distorted like losing their antialiasing
- Click "Discard" to close Compose window and the fonts become normal again.

This seems to be due the Flash plugin (Compose window uses it for attachments), if you disable Flash bug will not reproduce.
Comment 1 Ismail Donmez 2011-02-09 03:58:40 PST
Created attachment 81786 [details]
Fonts before I click on compose window
Comment 2 Ismail Donmez 2011-02-09 03:59:10 PST
Created attachment 81787 [details]
Font distortion with compose window open
Comment 3 Ismail Donmez 2011-02-09 04:02:52 PST
Also note that this only happens with WebKit, won't reproduce in Chrome either.
Comment 4 Ismail Donmez 2011-02-25 04:18:39 PST
To reproduce the issue you need to enable "Rich formatting" in the compose window, if you disabled it.
Comment 5 Simon Fraser (smfr) 2011-02-25 08:48:29 PST

*** This bug has been marked as a duplicate of bug 23364 ***