Bug 53842 - WAI-ARIA @aria-sort not exposed on rowheader and columnheader roles
Summary: WAI-ARIA @aria-sort not exposed on rowheader and columnheader roles
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: chris fleizach
URL:
Keywords:
: 53876 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-04 22:02 PST by chris fleizach
Modified: 2013-07-09 09:49 PDT (History)
1 user (show)

See Also:


Attachments
Patch (8.57 KB, patch)
2011-02-06 21:14 PST, chris fleizach
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description chris fleizach 2011-02-04 22:02:07 PST
WAI-ARIA @aria-sort not exposed on rowheader and column header roles

Cocoa table headers are exposed as AXSortButtons, and ARIA table headers are cells. However, ARIA row and col headers can contain an aria-sort attribute with the following values for:

AXSortDirection: AXAscendingSortDirection | AXDescendingSortDirection
Comment 1 chris fleizach 2011-02-06 20:56:12 PST
*** Bug 53876 has been marked as a duplicate of this bug. ***
Comment 2 chris fleizach 2011-02-06 21:14:43 PST
Created attachment 81448 [details]
Patch
Comment 3 Darin Adler 2011-02-07 08:15:00 PST
Comment on attachment 81448 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=81448&action=review

> Source/WebCore/accessibility/mac/AccessibilityObjectWrapper.mm:1990
> +        switch (m_object->sortDirection()) {
> +            case SortDirectionAscending:
> +                return NSAccessibilityAscendingSortDirectionValue;
> +            case SortDirectionDescending:
> +                return NSAccessibilityDescendingSortDirectionValue;
> +            default:
> +                return NSAccessibilityUnknownSortDirectionValue;
> +        }

WebKit style doesn't indent the case inside the switch.
Comment 4 chris fleizach 2011-02-07 09:15:23 PST
Comment on attachment 81448 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=81448&action=review

thanks for the review

>> Source/WebCore/accessibility/mac/AccessibilityObjectWrapper.mm:1990
>> +        }
> 
> WebKit style doesn't indent the case inside the switch.

strange that the style bot didn't catch this one
Comment 5 chris fleizach 2011-02-07 09:24:34 PST
http://trac.webkit.org/changeset/77820
Comment 6 James Craig 2013-07-09 09:49:22 PDT
See also: 
Bug 118511: AX: WebKit doesn't map aria-sort=other