Bug 53746 - [wx] ASSERTION FAILED: vptr() == JSGlobalData::jsArrayVPtr
Summary: [wx] ASSERTION FAILED: vptr() == JSGlobalData::jsArrayVPtr
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-03 17:49 PST by dennis
Modified: 2011-02-10 16:44 PST (History)
2 users (show)

See Also:


Attachments
Patch files (1.94 KB, application/x-gzip)
2011-02-03 17:49 PST, dennis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description dennis 2011-02-03 17:49:35 PST
Created attachment 81160 [details]
Patch files

I cannot choose the version i really use.
The right version i use is WebKit-r68833.tar.bz2.
I want to use "E-Texteditor" under Ubuntu 10.10 X86_64. Compiling Webkit is a part of this.
I also have to patch the files with attached patches.

Compiling works great.

But when i try to use the WebPreview Feature twice time in any way in E-Texteditor, the program crashes with the following error:

read(5, 0x32ee424, 4096) = -1 EAGAIN (Resource temporarily unavailable)
read(5, 0x32ee424, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=10, events=POLLIN}, {fd=15, events=POLLIN}, {fd=15, events=POLLOUT}, {fd=20, events=POLLIN}, {fd=9, events=POLLIN}, {fd=13, events=POLLIN}], 8, 0) = 0 (Timeout)
write(2, "ASSERTION FAILED: vptr() == JSGl"..., 54ASSERTION FAILED: vptr() == JSGlobalData::jsArrayVPtr
) = 54
write(2, "(../JavascriptCore/runtime/JSArr"..., 77(../JavascriptCore/runtime/JSArray.cpp:220 virtual JSC::JSArray::~JSArray())
) = 77
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Speicherzugriffsfehler

I think it's caused by Webkit cause JSArray.cpp is a part of this project.
Maybe you can help me.
Thanx a lot.

dennis
Comment 1 Patrick R. Gansterer 2011-02-08 16:14:52 PST
Did you try this with current trunk? r68833 is pretty old...
Comment 2 dennis 2011-02-08 16:24:38 PST
(In reply to comment #1)
> Did you try this with current trunk? r68833 is pretty old...

Thanx i'll try this
Comment 3 dennis 2011-02-10 16:26:31 PST
(In reply to comment #1)
> Did you try this with current trunk? r68833 is pretty old...

Pity, but i cannot apply the patch that is needed by e-texteditor building.
Comment 4 Patrick R. Gansterer 2011-02-10 16:44:32 PST
Sorry, but I'll close this as invalid.
If you use a patched(!) WebKit source and can't try this with the current trunk you should ask for help downstream.
Feel free to reopen this bug, when you're able to reprodice the failure with an actual version.