Bug 53684 - libwebkitgtk-1.0-0 crashes on amd64 architecture with SIGSEGV in WTF::OSAllocator::reserveAndCommit()
: libwebkitgtk-1.0-0 crashes on amd64 architecture with SIGSEGV in WTF::OSAlloc...
Status: RESOLVED DUPLICATE of bug 42756
: WebKit
JavaScriptCore
: 420+
: PC Linux
: P2 Normal
Assigned To:
: https://bugs.launchpad.net/ubuntu/+so...
: Gtk
:
:
  Show dependency treegraph
 
Reported: 2011-02-03 08:10 PST by
Modified: 2011-02-03 12:27 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-02-03 08:10:52 PST
Users of ubuntu natty are experiencing a sigsegv of libwebkitgtk-1.0-0 in  WTF::OSAllocator::reserveAndCommit()  on amd64 platforms.
The original bug report was made here:
https://bugs.launchpad.net/ubuntu/+source/webkit/+bug/710582 

a backtrace kan be found here:
http://launchpadlibrarian.net/63485933/gdb-gwibber-accounts.txt
and a valgrind log here:
https://bugs.launchpad.net/ubuntu/+source/epiphany-browser/+bug/704393/+attachment/1827136/+files/gwibber-accounts-valgrind.log

several people can reproduce this bug. F.ex by starting up gwibber-accounts and trying to add a new twitter account. Or by using the ubiquity installer.
------- Comment #1 From 2011-02-03 11:33:43 PST -------
I think this might be a dupe. CCing Xan who should definitely know.
------- Comment #2 From 2011-02-03 12:09:14 PST -------
The trace is different, but it definitely looks like bug 42756. To double check enable overcommit and see if it stops happening (echo 1 > /proc/sys/vm/overcommit).
------- Comment #3 From 2011-02-03 12:23:57 PST -------
echo 1 > /proc/sys/vm/overcommit_memory
does fix the problem!
------- Comment #4 From 2011-02-03 12:27:21 PST -------
Thanks for reporting this issue! Please refer to the earlier issue for updates.

*** This bug has been marked as a duplicate of bug 42756 ***