Bug 53681 - REGRESSION: Can't link WebCore on 32-bit Leopard
Summary: REGRESSION: Can't link WebCore on 32-bit Leopard
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://build.webkit.org/builders/Leop...
Keywords: InRadar, PlatformOnly
Depends on:
Blocks:
 
Reported: 2011-02-03 07:07 PST by Adam Roben (:aroben)
Modified: 2011-02-08 10:15 PST (History)
2 users (show)

See Also:


Attachments
Fix the Leopard 32bit debug build. (30.49 KB, patch)
2011-02-07 17:41 PST, Lucas Forschler
webkit.review.bot: review-
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2011-02-03 07:07:14 PST
WebCore is failing to link on 32-bit Leopard, with the following errors:


Ld /Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/WebKitBuild/Debug/WebCore.framework/Versions/A/WebCore normal i386
    cd /Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/Source/WebCore
    /Developer/usr/bin/g++-4.2 -arch i386 -dynamiclib -L/Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/WebKitBuild/Debug -F/Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/WebKitBuild/Debug -F/System/Library/Frameworks/Carbon.framework/Frameworks -F/System/Library/Frameworks/ApplicationServices.framework/Frameworks -filelist /Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/WebKitBuild/WebCore.build/Debug/WebCore.build/Objects-normal/i386/WebCore.LinkFileList -Wl,--no-demangle -exported_symbols_list /Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/WebKitBuild/Debug/DerivedSources/WebCore/WebCore.exp -install_name /Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/WebKitBuild/Debug/WebCore.framework/Versions/A/WebCore -mmacosx-version-min=10.5 -lWebCoreSQLite3 -lobjc -lANGLE -sub_library libobjc -umbrella WebKit -framework Accelerate -framework ApplicationServices -framework AudioToolbox -framework AudioUnit -framework Carbon -framework Cocoa -framework CoreAudio -framework IOKit -framework JavaScriptCore -licucore -lobjc -lxml2 -lz -framework OpenGL -framework QuartzCore -framework SystemConfiguration -Wl,-single_module -compatibility_version 1 -current_version 534.17 -o /Volumes/Big/WebKit-BuildSlave/leopard-intel-debug/build/WebKitBuild/Debug/WebCore.framework/Versions/A/WebCore
collect2: ld terminated with signal 6 [Abort trap]
ld(81604) malloc: *** mmap(size=68210688) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
ld(81604) malloc: *** mmap(size=33333248) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc

A quick Google search indicates that this is due to the linker running out of address space.
Comment 1 Adam Roben (:aroben) 2011-02-03 07:07:34 PST
We've had this problem on Windows before, and have fixed it by combining multiple .cpp files into a single *AllInOne.cpp file.
Comment 2 Adam Roben (:aroben) 2011-02-03 07:08:07 PST
This started happening between r77358 and r77360, but I don't think those revisions are directly to blame.
Comment 3 Adam Roben (:aroben) 2011-02-03 07:08:25 PST
<rdar://problem/8953606>
Comment 4 Lucas Forschler 2011-02-07 17:41:27 PST
Created attachment 81558 [details]
Fix the Leopard 32bit debug build.

This could break windows.  Will watch EWS to make sure.
Comment 5 WebKit Review Bot 2011-02-07 17:48:54 PST
Comment on attachment 81558 [details]
Fix the Leopard 32bit debug build.

Rejecting attachment 81558 [details] from review queue.

lforschler@apple.com does not have reviewer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have reviewer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have reviewer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your reviewer rights.
Comment 6 WebKit Review Bot 2011-02-07 17:59:35 PST
Comment on attachment 81558 [details]
Fix the Leopard 32bit debug build.

Rejecting attachment 81558 [details] from commit-queue.

lforschler@apple.com does not have committer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 7 Lucas Forschler 2011-02-08 10:15:37 PST
http://trac.webkit.org/changeset/77878