Bug 53577 - A little more Heap refactoring
Summary: A little more Heap refactoring
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Geoffrey Garen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-01 23:09 PST by Geoffrey Garen
Modified: 2011-02-02 11:21 PST (History)
1 user (show)

See Also:


Attachments
Patch (31.51 KB, patch)
2011-02-01 23:18 PST, Geoffrey Garen
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2011-02-01 23:09:06 PST
A little more Heap refactoring
Comment 1 Geoffrey Garen 2011-02-01 23:18:05 PST
Created attachment 80894 [details]
Patch
Comment 2 WebKit Review Bot 2011-02-01 23:20:59 PST
Attachment 80894 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/Android.mk', u'Sourc..." exit_code: 1

Source/JavaScriptCore/runtime/MarkedBlock.h:30:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:34:  BLOCK_SIZE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:36:  BLOCK_SIZE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:39:  BLOCK_OFFSET_MASK is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:40:  BLOCK_MASK is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:41:  MINIMUM_CELL_SIZE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:42:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/JavaScriptCore/runtime/MarkedBlock.h:42:  CELL_ARRAY_LENGTH is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:43:  CELL_SIZE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:44:  SMALL_CELL_SIZE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:45:  CELL_MASK is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:46:  CELL_ALIGN_MASK is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:47:  CELLS_PER_BLOCK is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:62:  The parameter name "cell" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/runtime/MarkedBlock.h:63:  The parameter name "cell" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/runtime/MarkedBlock.h:64:  The parameter name "cell" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/runtime/MarkedBlock.h:65:  The parameter name "cell" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 17 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Sam Weinig 2011-02-02 11:16:59 PST
Comment on attachment 80894 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=80894&action=review

>> Source/JavaScriptCore/runtime/MarkedBlock.h:65
>> +        void setMarked(JSCell* cell);
> 
> The parameter name "cell" adds no information, so it should be removed.  [readability/parameter_name] [5]

You don't need the parameter names here.
Comment 4 Geoffrey Garen 2011-02-02 11:21:28 PST
Committed r77391: <http://trac.webkit.org/changeset/77391>