Bug 53319 - [Qt] QWebElement set and get attribute
Summary: [Qt] QWebElement set and get attribute
Status: RESOLVED DUPLICATE of bug 32865
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 312.x
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2011-01-28 11:58 PST by 2beers
Modified: 2011-01-28 19:12 PST (History)
1 user (show)

See Also:


Attachments
small project to see what happens (3.91 KB, application/x-rar)
2011-01-28 11:58 PST, 2beers
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description 2beers 2011-01-28 11:58:54 PST
Created attachment 80474 [details]
small project to see what happens

QWebElement.setAttribute is not working once you modified the html element from the webkit widget or you changed the value using javascript.

on the HTML side I have something like this:

<input tye="text" id="firstname" value="" />


on Qt side I have something like this:

QWebFrame *frame = ui->webView->page()->mainFrame();
QWebElement firstName = frame->findFirstElement("#firstname");
firstName.setAttribute("value","some text");

it works only if I don't manually change the value ,else it doesn't do anything


http://www.mediafire.com/?erroif6ubllbubd here is a small project to see how it happens.
here is a youtube video to see when the error appears: http://www.youtube.com/watch?v=2R63Me6CuI4


you can read more on this conversation: http://developer.qt.nokia.com/forums/viewthread/3389/
Comment 1 Benjamin Poulain 2011-01-28 12:27:25 PST
Confirmed.
Comment 2 Benjamin Poulain 2011-01-28 19:12:18 PST

*** This bug has been marked as a duplicate of bug 32865 ***