Bug 53274 - WebKit2: Page flashes just before accelerated compositing animation
Summary: WebKit2: Page flashes just before accelerated compositing animation
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Chris Marrin
URL: http://www.apple.com/startpage
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-01-27 17:43 PST by Chris Marrin
Modified: 2011-01-28 11:49 PST (History)
2 users (show)

See Also:


Attachments
Patch (1.55 KB, patch)
2011-01-27 17:52 PST, Chris Marrin
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Marrin 2011-01-27 17:43:01 PST
When you reload this page in a WebKit2 window, the page will flash to white after to top button bar finishes it's roll down  animation

The problem is that after that animation, the page switches out of compositing mode momentarily and the change in renderers causes a flash

When switching out of compositing mode, the new ChunkedUpdateDrawingAreaProxy is getting created with the current page size. When the setSize() call is subsequently made, the sizeDidChange() call is not made (which does the initial render of the page) because the old size and new size are the same. The solution is to skip the setting of the size in the ctor and let it go  through a size change sequence.
Comment 1 Chris Marrin 2011-01-27 17:43:22 PST
rdar://problem/8711567
Comment 2 Chris Marrin 2011-01-27 17:52:03 PST
Created attachment 80389 [details]
Patch
Comment 3 Anders Carlsson 2011-01-28 10:11:35 PST
Comment on attachment 80389 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=80389&action=review

> Source/WebKit2/ChangeLog:12
> +        is to skip the setting of the size in the ctor and let it go  through a size 

Extra space.
Comment 4 Chris Marrin 2011-01-28 11:49:12 PST
Committed r76962: <http://trac.webkit.org/changeset/76962>