The WebGL working group resolved at the most recent face-to-face to rename the slice() method on Typed Arrays to subset() to avoid collisions with ECMAScript arrays' slice() method, because Typed Arrays' slices have slightly different semantics (they reference the same underlying data instead of copying it). The WebKit implementation needs to be changed to track this and the conformance tests updated.
Created attachment 80385 [details]
Comment on attachment 80385 [details]
R=me. I hope it compiles everywhere :)
Committed r76892: <http://trac.webkit.org/changeset/76892>