Bug 53187 - input[type=url] should allow URL fixup behind the scenes
Summary: input[type=url] should allow URL fixup behind the scenes
Status: RESOLVED DUPLICATE of bug 29235
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://www.whatwg.org/specs/web-apps/...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-26 12:49 PST by Erik Arvidsson
Modified: 2011-01-26 15:38 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Arvidsson 2011-01-26 12:49:47 PST
The URL input currently takes the text written by the user literally and uses that as the value. It would be much more useful if we allowed URL fixup to happen. For example, if the user types "webkit.org" the value should be "http://webkit.org".

This issue has forced us to change the type of URL inputs to text which defeats a lot of the purpose.
Comment 1 Kent Tamura 2011-01-26 15:38:43 PST

*** This bug has been marked as a duplicate of bug 29235 ***