Bug 52850 - Shift-tab doesn't cycle through fields in http authentication panel
Summary: Shift-tab doesn't cycle through fields in http authentication panel
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac All
: P2 Normal
Assignee: John Sullivan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-20 15:42 PST by John Sullivan
Modified: 2019-03-20 21:02 PDT (History)
2 users (show)

See Also:


Attachments
Patch that rewires the nextKeyView loop. (21.78 KB, patch)
2011-01-20 15:44 PST, John Sullivan
mrowe: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Sullivan 2011-01-20 15:42:24 PST
To reproduce:

1. visit any page that brings up the HTTP authentication dialog
2. hit Tab repeatedly -- note that it cycles through the two text fields repeatedly (or more controls depending on your systemwide "Tab to all controls" setting).
3. hit Shift-Tab repeatedly

Note that it does not cycle through the two text fields repeatedly.
Comment 1 John Sullivan 2011-01-20 15:43:30 PST
The problem is that the nib file has an invalid nextKeyView loop. Two views have the password field as their nextKeyView.
Comment 2 John Sullivan 2011-01-20 15:44:31 PST
Created attachment 79660 [details]
Patch that rewires the nextKeyView loop.